Bug 1298755 - rhel-osp-director: Update undercloud 7.1->7.2, rerun "openstack undercloud install" tuskar errors.
rhel-osp-director: Update undercloud 7.1->7.2, rerun "openstack undercloud in...
Status: CLOSED DUPLICATE of bug 1298757
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: chris alfonso
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-14 17:51 EST by Alexander Chuzhoy
Modified: 2016-04-18 03:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-14 19:10:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Chuzhoy 2016-01-14 17:51:46 EST
rhel-osp-director: Update undercloud 7.1->7.2, rerun "openstack undercloud install" tuskar errors.

Environment:
instack-undercloud-2.1.2-36.el7ost.noarch
openstack-tripleo-common-0.0.1.dev6-5.git49b57eb.el7ost.noarch
openstack-tripleo-0.0.7-0.1.1664e566.el7ost.noarch
openstack-tripleo-image-elements-0.9.6-10.el7ost.noarch
openstack-tuskar-ui-extras-0.0.4-2.el7ost.noarch
python-tuskarclient-0.1.18-5.el7ost.noarch
openstack-tuskar-0.4.18-5.el7ost.noarch
openstack-tuskar-ui-0.4.0-5.el7ost.noarch
openstack-tripleo-heat-templates-0.8.6-94.el7ost.noarch
openstack-tripleo-puppet-elements-0.0.1-5.el7ost.noarch



Steps to reproduce:
1. Deploy undercloud 7.1
2. Update the undercloud to 7.2
3. Rerun "openstack undercloud install"

Result:
Errors during run:

dib-run-parts Thu Jan 14 17:45:26 EST 2016 Running /usr/libexec/os-refresh-config/post-configure.d/101-plan-add-roles                                                                                                
grep: 5b9d5c74-f75e-48e8-b4ce-47aa135b6cca: No such file or directory                                                                                                                                                
ERROR (shell) Exiting due to an error:                                                                                                                                                                               
Traceback (most recent call last):                                                                                                                                                                                   
  File "/usr/lib/python2.7/site-packages/tuskarclient/shell.py", line 248, in main                                                                                                                                   
    TuskarShell(sys.argv[1:]).run()                                                                                                                                                                                  
  File "/usr/lib/python2.7/site-packages/tuskarclient/shell.py", line 76, in run                                                                                                                                     
    args.func(tuskar_client, args)                                                                                                                                                                                   
  File "/usr/lib/python2.7/site-packages/tuskarclient/v2/plans_shell.py", line 50, in do_plan_show                                                                                                                   
    print_plan_summary(plan, outfile=outfile)                                                                                                                                                                        
  File "/usr/lib/python2.7/site-packages/tuskarclient/v2/plans_shell.py", line 64, in print_plan_summary                                                                                                             
    fmt.print_dict(plan_dict, formatters, outfile=outfile)                                                                                                                                                           
  File "/usr/lib/python2.7/site-packages/tuskarclient/common/formatting.py", line 132, in print_dict                                                                                                                 
    print(pt.get_string(sortby='Property'), file=outfile)                                                                                                                                                            
IOError: [Errno 32] Broken pipe                                                                                                                                                                                      
usage: tuskar [-h] [--version] [-d] [--os-username OS_USERNAME]                                                                                                                                                      
              [--os-password OS_PASSWORD] [--os-tenant-id OS_TENANT_ID]                                                                                                                                              
              [--os-tenant-name OS_TENANT_NAME] [--os-auth-url OS_AUTH_URL]                                                                                                                                          
              [--os-auth-token OS_AUTH_TOKEN] [--tuskar-url TUSKAR_URL]                                                                                                                                              
              [--tuskar-api-version TUSKAR_API_VERSION] [--insecure]                                                                                                                                                 
              [--os-cacert <ca-certificate>] [--os-cert <certificate>]                                                                                                                                               
              [--os-key <key>] [--timeout <seconds>]                                                                                                                                                                 
              <subcommand> ...                                                                                                                                                                                       
tuskar: error: unrecognized arguments: 5b9d5c74-f75e-48e8-b4ce-47aa135b6cca                                                                                                                                          
grep: 827428d1-9fa7-42c6-bd06-7a7cd1c9b60a: No such file or directory                                                                                                                                                
ERROR (shell) Exiting due to an error:                                                                                                                                                                               
Traceback (most recent call last):                                                                                                                                                                                   
  File "/usr/lib/python2.7/site-packages/tuskarclient/shell.py", line 248, in main                                                                                                                                   
    TuskarShell(sys.argv[1:]).run()                                                                                                                                                                                  
  File "/usr/lib/python2.7/site-packages/tuskarclient/shell.py", line 76, in run                                                                                                                                     
    args.func(tuskar_client, args)                                                                                                                                                                                   
  File "/usr/lib/python2.7/site-packages/tuskarclient/v2/plans_shell.py", line 50, in do_plan_show                                                                                                                   
    print_plan_summary(plan, outfile=outfile)                                                                                                                                                                        
  File "/usr/lib/python2.7/site-packages/tuskarclient/v2/plans_shell.py", line 64, in print_plan_summary                                                                                                             
    fmt.print_dict(plan_dict, formatters, outfile=outfile)                                                                                                                                                           
  File "/usr/lib/python2.7/site-packages/tuskarclient/common/formatting.py", line 132, in print_dict                                                                                                                 
    print(pt.get_string(sortby='Property'), file=outfile)                                                                                                                                                            
IOError: [Errno 32] Broken pipe                                                                                                                                                                                      
usage: tuskar [-h] [--version] [-d] [--os-username OS_USERNAME]                                                                                                                                                      
              [--os-password OS_PASSWORD] [--os-tenant-id OS_TENANT_ID]                                                                                                                                              
              [--os-tenant-name OS_TENANT_NAME] [--os-auth-url OS_AUTH_URL]                                                                                                                                          
              [--os-auth-token OS_AUTH_TOKEN] [--tuskar-url TUSKAR_URL]                                                                                                                                              
              [--tuskar-api-version TUSKAR_API_VERSION] [--insecure]                                                                                                                                                 
              [--os-cacert <ca-certificate>] [--os-cert <certificate>]                                                                                                                                               
              [--os-key <key>] [--timeout <seconds>]                                                                                                                                                                 
              <subcommand> ...                                                                                                                                                                                       
tuskar: error: unrecognized arguments: 827428d1-9fa7-42c6-bd06-7a7cd1c9b60a                                                                                                                                          
grep: 9e0b0da5-b5ff-448e-bc0c-36d1a3484a54: No such file or directory                                                                                                                                                
ERROR (shell) Exiting due to an error:                                                                                                                                                                               
Traceback (most recent call last):                                                                                                                                                                                   
  File "/usr/lib/python2.7/site-packages/tuskarclient/shell.py", line 248, in main                                                                                                                                   
    TuskarShell(sys.argv[1:]).run()                                                                                                                                                                                  
  File "/usr/lib/python2.7/site-packages/tuskarclient/shell.py", line 76, in run                                                                                                                                     
    args.func(tuskar_client, args)                                                                                                                                                                                   
  File "/usr/lib/python2.7/site-packages/tuskarclient/v2/plans_shell.py", line 50, in do_plan_show                                                                                                                   
    print_plan_summary(plan, outfile=outfile)                                                                                                                                                                        
  File "/usr/lib/python2.7/site-packages/tuskarclient/v2/plans_shell.py", line 64, in print_plan_summary                                                                                                             
    fmt.print_dict(plan_dict, formatters, outfile=outfile)                                                                                                                                                           
  File "/usr/lib/python2.7/site-packages/tuskarclient/common/formatting.py", line 132, in print_dict                                                                                                                 
    print(pt.get_string(sortby='Property'), file=outfile)                                                                                                                                                            
IOError: [Errno 32] Broken pipe                                                                                                                                                                                      
usage: tuskar [-h] [--version] [-d] [--os-username OS_USERNAME]                                                                                                                                                      
              [--os-password OS_PASSWORD] [--os-tenant-id OS_TENANT_ID]                                                                                                                                              
              [--os-tenant-name OS_TENANT_NAME] [--os-auth-url OS_AUTH_URL]                                                                                                                                          
              [--os-auth-token OS_AUTH_TOKEN] [--tuskar-url TUSKAR_URL]                                                                                                                                              
              [--tuskar-api-version TUSKAR_API_VERSION] [--insecure]                                                                                                                                                 
              [--os-cacert <ca-certificate>] [--os-cert <certificate>]                                                                                                                                               
              [--os-key <key>] [--timeout <seconds>]                                                                                                                                                                 
              <subcommand> ...                                                                                                                                                                                       
tuskar: error: unrecognized arguments: 9e0b0da5-b5ff-448e-bc0c-36d1a3484a54                                                                                                                                          
grep: a6391369-4c07-43f9-b884-257efe3a76b6: No such file or directory                                                                                                                                                
ERROR (shell) Exiting due to an error:                                                                                                                                                                               
Traceback (most recent call last):                                                                                                                                                                                   
  File "/usr/lib/python2.7/site-packages/tuskarclient/shell.py", line 248, in main                                                                                                                                   
    TuskarShell(sys.argv[1:]).run()                                                                                                                                                                                  
  File "/usr/lib/python2.7/site-packages/tuskarclient/shell.py", line 76, in run                                                                                                                                     
    args.func(tuskar_client, args)                                                                                                                                                                                   
  File "/usr/lib/python2.7/site-packages/tuskarclient/v2/plans_shell.py", line 50, in do_plan_show                                                                                                                   
    print_plan_summary(plan, outfile=outfile)                                                                                                                                                                        
  File "/usr/lib/python2.7/site-packages/tuskarclient/v2/plans_shell.py", line 64, in print_plan_summary                                                                                                             
    fmt.print_dict(plan_dict, formatters, outfile=outfile)                                                                                                                                                           
  File "/usr/lib/python2.7/site-packages/tuskarclient/common/formatting.py", line 132, in print_dict                                                                                                                 
    print(pt.get_string(sortby='Property'), file=outfile)                                                                                                                                                            
IOError: [Errno 32] Broken pipe                                                                                                                                                                                      
usage: tuskar [-h] [--version] [-d] [--os-username OS_USERNAME]                                                                                                                                                      
              [--os-password OS_PASSWORD] [--os-tenant-id OS_TENANT_ID]                                                                                                                                              
              [--os-tenant-name OS_TENANT_NAME] [--os-auth-url OS_AUTH_URL]                                                                                                                                          
              [--os-auth-token OS_AUTH_TOKEN] [--tuskar-url TUSKAR_URL]                                                                                                                                              
              [--tuskar-api-version TUSKAR_API_VERSION] [--insecure]                                                                                                                                                 
              [--os-cacert <ca-certificate>] [--os-cert <certificate>]                                                                                                                                               
              [--os-key <key>] [--timeout <seconds>]                                                                                                                                                                 
              <subcommand> ...                                                                                                                                                                                       
tuskar: error: unrecognized arguments: a6391369-4c07-43f9-b884-257efe3a76b6                                                                                                                                          
grep: bfa324ae-7711-48d5-9ffa-dd843c068442: No such file or directory                                                                                                                                                
ERROR (shell) Exiting due to an error:                                                                                                                                                                               
Traceback (most recent call last):                                                                                                                                                                                   
  File "/usr/lib/python2.7/site-packages/tuskarclient/shell.py", line 248, in main                                                                                                                                   
    TuskarShell(sys.argv[1:]).run()                                                                                                                                                                                  
  File "/usr/lib/python2.7/site-packages/tuskarclient/shell.py", line 76, in run                                                                                                                                     
    args.func(tuskar_client, args)                                                                                                                                                                                   
  File "/usr/lib/python2.7/site-packages/tuskarclient/v2/plans_shell.py", line 50, in do_plan_show                                                                                                                   
    print_plan_summary(plan, outfile=outfile)                                                                                                                                                                        
  File "/usr/lib/python2.7/site-packages/tuskarclient/v2/plans_shell.py", line 64, in print_plan_summary                                                                                                             
    fmt.print_dict(plan_dict, formatters, outfile=outfile)                                                                                                                                                           
  File "/usr/lib/python2.7/site-packages/tuskarclient/common/formatting.py", line 132, in print_dict                                                                                                                 
    print(pt.get_string(sortby='Property'), file=outfile)                                                                                                                                                            
IOError: [Errno 32] Broken pipe                                                                                                                                                                                      
usage: tuskar [-h] [--version] [-d] [--os-username OS_USERNAME]
              [--os-password OS_PASSWORD] [--os-tenant-id OS_TENANT_ID]
              [--os-tenant-name OS_TENANT_NAME] [--os-auth-url OS_AUTH_URL]
              [--os-auth-token OS_AUTH_TOKEN] [--tuskar-url TUSKAR_URL]
              [--tuskar-api-version TUSKAR_API_VERSION] [--insecure]
              [--os-cacert <ca-certificate>] [--os-cert <certificate>]
              [--os-key <key>] [--timeout <seconds>]
              <subcommand> ...
tuskar: error: unrecognized arguments: bfa324ae-7711-48d5-9ffa-dd843c068442



Note: The run seems to complete successfully despite the errors.
Comment 2 Mike Burns 2016-01-14 19:10:08 EST

*** This bug has been marked as a duplicate of bug 1298757 ***

Note You need to log in before you can comment on or make changes to this bug.