Bug 1298821 - perl-Data-ObjectDriver-0.13-3.fc24 FTBFS: Failed test 'removing all bad wine' at t/02-basic.t line 248
perl-Data-ObjectDriver-0.13-3.fc24 FTBFS: Failed test 'removing all bad wine'...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Data-ObjectDriver (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Emmanuel Seyman
Fedora Extras Quality Assurance
https://github.com/sixapart/data-obje...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-15 02:58 EST by Petr Pisar
Modified: 2016-01-15 07:57 EST (History)
2 users (show)

See Also:
Fixed In Version: perl-Data-ObjectDriver-0.14-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-15 07:57:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2016-01-15 02:58:10 EST
perl-Data-ObjectDriver-0.13-3.fc24 fails to build in F24 because a test fails:

t/01-col-inheritance.t ..... ok
#   Failed test 'removing all bad wine'
#   at t/02-basic.t line 248.
#          got: '3'
#     expected: '0E0'
# Looks like you failed 1 test of 67.
t/02-basic.t ............... 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/67 subtests 

Difference between working and failing build root is:

        glibc 	2.22.90-27.fc24 	> 	2.22.90-29.fc24
	sqlite 	3.9.2-1.fc24 	> 	3.10.0-1.fc24
	glibc-common 	2.22.90-27.fc24 	> 	2.22.90-29.fc24
	glibc-devel 	2.22.90-27.fc24 	> 	2.22.90-29.fc24
	elfutils-libelf 	0.165-1.fc24 	> 	0.165-2.fc24
	elfutils-default-yama-scope 	0.165-1.fc24 	> 	0.165-2.fc24
	coreutils-common 	8.24-105.fc24 	> 	8.24-106.fc24
	python-srpm-macros 		> 	3-4.fc24
	coreutils 	8.24-105.fc24 	> 	8.24-106.fc24
	python3-libs 	3.5.1-2.fc24 	> 	3.5.1-3.fc24
	gnupg2 	2.1.10-1.fc24 	> 	2.1.10-3.fc24
	glibc-headers 	2.22.90-27.fc24 	> 	2.22.90-29.fc24
	elfutils-libs 	0.165-1.fc24 	> 	0.165-2.fc24
	redhat-rpm-config 	36-1.fc24 	> 	39-1.fc24
	elfutils 	0.165-1.fc24 	> 	0.165-2.fc24
	python3 	3.5.1-2.fc24 	> 	3.5.1-3.fc24
Comment 1 Petr Pisar 2016-01-15 03:03:51 EST
This is cause by upgrading sqlite from 3.9.2-1.fc24 to 3.10.0-1.fc24.
Comment 2 Petr Pisar 2016-01-15 03:05:28 EST
Upstream released Data-ObjectDriver-0.14 that should fix it.
Comment 3 Emmanuel Seyman 2016-01-15 07:57:41 EST
Indeed. Updated and buitl for rawhide

Note You need to log in before you can comment on or make changes to this bug.