Bug 1298834 - Overcloud update fails: Yum update on compute fails because of dependencies issues on the compute nodes.
Overcloud update fails: Yum update on compute fails because of dependencies i...
Status: CLOSED CANTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 10.0 (Newton)
Assigned To: Jiri Stransky
Shai Revivo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-15 03:54 EST by Qasim Sarfraz
Modified: 2016-10-09 23:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-09 23:55:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qasim Sarfraz 2016-01-15 03:54:21 EST
Description of problem:
I was trying to upgrade my RHEL-OSP 7.1 cluster to RHEL-OSP 7.2. I ran following command to upgrade my setup:
openstack overcloud update stack overcloud -i  --templates  openstack-tripleo-heat-templates/  -e openstack-tripleo-heat-templates/overcloud-resource-registry-puppet.yaml  -e /home/stack/upgrade-params.yaml

Version-Release number of selected component (if applicable): 7.1 -> 7.2 


How reproducible:

Bring up RHEL-OSP 7.1
Upgrade it too RHEL-OSP 7.2.
yum_update.sh fails on the compute nodes


Expected results:
Update should be successful.
Comment 2 Mike Burns 2016-04-07 17:03:37 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 4 Jaromir Coufal 2016-10-09 23:55:48 EDT
Can't reproduce, passes our CI. If re-appears please re-open with logs.

Note You need to log in before you can comment on or make changes to this bug.