Bug 1298892 - No kickstart installation via network
No kickstart installation via network
Status: CLOSED DUPLICATE of bug 1280448
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-15 06:36 EST by Jürgen Holm
Modified: 2016-01-18 08:39 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-18 08:39:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fedora-23-min.x86_64.cfg (1.93 KB, text/plain)
2016-01-18 05:05 EST, Jürgen Holm
no flags Details
log of anaconda (481 bytes, text/plain)
2016-01-18 05:06 EST, Jürgen Holm
no flags Details
storage log (794 bytes, text/plain)
2016-01-18 05:09 EST, Jürgen Holm
no flags Details
prgramm log (261 bytes, text/plain)
2016-01-18 05:09 EST, Jürgen Holm
no flags Details

  None (edit)
Description Jürgen Holm 2016-01-15 06:36:00 EST
Description of problem:
Anaconda did not read Kickstart file via network inst.ks=(ftp|http)


Version-Release number of selected component (if applicable):
FC23

How reproducible:
always

Steps to Reproduce:
Use PXE boot for installation and eg. a RedHat tftpd server with this configuration:
label fc23test
  kernel FC23/x86_64/vmlinuz
  append inst.selinux=0 selinux=0 initrd=FC23/x86_64/initrd.img inst.stage2=ftp://rpm/fedora/linux/releases/23/Server/x86_64/os inst.repo=ftp://rpm/fedora/linux/releases/23/Everything/x86_64/os noipv6  inst.ks=ftp://rpm/auto_inst/fedora-23-test.x86_64.cfg


Actual results:
Kickstart file is loaded from the ftp server (seen in the ftpd log) but not read by Anaconda. You get the message: Kickstart file not found"

Additional info:
Fix: Do not use this UNUSEABLE anacoda version, use anaconda from FC21 for a 23 installation:

 label fc23test
  kernel FC21/x86_64/vmlinuz
  append inst.selinux=0 selinux=0 initrd=FC21/x86_64/initrd.img inst.stage2=ftp://rpm/fedora/linux/releases/21/Server/x86_64/os inst.repo=ftp://rpm/fedora/linux/releases/23/Everything/x86_64/os noipv6  inst.ks=ftp://rpm/auto_inst/fedora-23-test.x86_64.cfg
Comment 1 David Shea 2016-01-15 08:27:20 EST
Can you attach the kickstart file you are using, with any passwords and other sensitive data removed? At what point does the file not found message occur? Before the message, do you see something like "anaconda 23.19.10-1 for Fedora 23 started", or something that looks like progress output from fetching the file over the network, or something else?
Comment 2 Jürgen Holm 2016-01-18 05:05 EST
Created attachment 1115792 [details]
fedora-23-min.x86_64.cfg

Used Kickstart file
Comment 3 Jürgen Holm 2016-01-18 05:06 EST
Created attachment 1115793 [details]
log of anaconda
Comment 4 Jürgen Holm 2016-01-18 05:09 EST
Created attachment 1115794 [details]
storage log
Comment 5 Jürgen Holm 2016-01-18 05:09 EST
Created attachment 1115795 [details]
prgramm log
Comment 6 Jürgen Holm 2016-01-18 05:15:59 EST
ifcfg.log packaging.log and sensitive-info.log are emtpy files.

ftp server transfer log:
Mon Jan 18 10:51:25 2016 0 134.76.88.196 1131 /mnt/theorie/rpm/fedora/linux/releases/23/Server/x86_64/os/.treeinfo b _ o a ftp@example.com ftp 0 * c
Mon Jan 18 10:51:29 2016 3 134.76.88.196 346673152 /mnt/theorie/rpm/fedora/linux/releases/23/Server/x86_64/os/images/install.img b _ o a ftp@example.com ftp 0 * c
Mon Jan 18 10:51:30 2016 0 134.76.88.196 3090 /mnt/theorie/rpm/auto_inst/fedora-23-min.x86_64.cfg b _ o a ftp@example.com ftp 0 * c
Comment 7 Jürgen Holm 2016-01-18 05:53:18 EST
After digging arround I found this in the journal:

File "/usr/lib/python3.4/site-packages/pykickstart/parser.py", line 124, in preprocessKickstart
contents = load_to_str(f)
File "/usr/lib/python3.4/site-packages/pykickstart/load.py", line 44, in load_to_str
return _load_file(location)
File "/usr/lib/python3.4/site-packages/pykickstart/load.py", line 93, in _load
contents = fh.read()
File "/usr/lib64/python3.4/encodings/ascii.py", line 26, in decode
return codecs.ascii_decode(input, self.errors)[0]
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 2410: ordinal not in range(128)

This is related to a comment in the Kickstart file:
# ldap Backend für sssd

So, utf8 in comments breaks anaconda! I thought the ASCII only time long gone.
Comment 8 David Shea 2016-01-18 08:39:31 EST

*** This bug has been marked as a duplicate of bug 1280448 ***

Note You need to log in before you can comment on or make changes to this bug.