Bug 1299028 - /sbin/runuser: cannot set user id: Resource temporarily unavailable error
/sbin/runuser: cannot set user id: Resource temporarily unavailable error
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Image (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Rory Thrasher
Wang Haoran
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-15 12:48 EST by romach007
Modified: 2016-01-18 09:54 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-18 09:54:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description romach007 2016-01-15 12:48:50 EST
Description of problem:

I have an Application with "WildFly Application Server 10" carteidge. URL - http://itevents2-romach.rhcloud.com/ . 

I see "500 - Internal Server Error"

When I try to make "rhc force-stop-app -a itevents2" command I get error:

Resources unavailable for operation. You may need to run 'rhc force-stop-app -a itevents2' and retry.
/sbin/runuser: cannot set user id: Resource temporarily unavailable

How can I stop or delete application?
Comment 1 Rory Thrasher 2016-01-15 17:43:12 EST
Hi there,

Our operations team has looked at your gear and stopped some processes that were still running.  You should be able to use the gear again.  Can you access your app and run rhc commands now?

I'm not sure what gear size you've been using, but we've seen similar problems with the Wildfly cartridge on small size gears.  Wildfly is an Enterprise Java application, which means it can use quite a bit of memory.  I believe the recommendation is to use a medium or large gear in order to avoid memory issues.  If you're using a small gear, then these problems may occur again.

Rory
Comment 2 romach007 2016-01-16 04:40:27 EST
> Can you access your app and run rhc commands now?

Yes, I can use my gear now.

> I'm not sure what gear size you've been using...

Yes, I have small gear.

Thank you? problem solved.
Comment 3 Rory Thrasher 2016-01-18 09:54:09 EST
Glad your gear is working!  Unfortunately with a small gear size, similar issues may happen again.  I would recommend upgrading to a medium or large gear size if you're looking to use the WildFly cartridge (you can see more information here: https://developers.openshift.com/en/wildfly-getting-started.html).

I'm going to go ahead and close this bug as it looks like the issue has been fixed.

Note You need to log in before you can comment on or make changes to this bug.