This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1299032 - atomic-openshift-installer install traceback in get_installed_hosts
atomic-openshift-installer install traceback in get_installed_hosts
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Samuel Munilla
Xiaoli Tian
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-15 13:09 EST by Eric Paris
Modified: 2016-09-06 14:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-06 14:14:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Paris 2016-01-15 13:09:58 EST
atomic-openshift-installer install
install OSE 3.1

ansible-2.0.0.1-1.fc23.noarch
atomic-openshift-utils-3.0.32-1.git.0.d98926d.el7aos.noarch
openshift-ansible-3.0.32-1.git.0.d98926d.el7aos.noarch
openshift-ansible-filter-plugins-3.0.32-1.git.0.d98926d.el7aos.noarch
openshift-ansible-lookup-plugins-3.0.32-1.git.0.d98926d.el7aos.noarch
openshift-ansible-playbooks-3.0.32-1.git.0.d98926d.el7aos.noarch
openshift-ansible-roles-3.0.32-1.git.0.d98926d.el7aos.noarch
python-2.7.10-8.fc23.x86_64

*** Installation Summary ***

Hosts:
- 192.168.122.195
  - OpenShift Master
  - OpenShift Node (Unscheduled)
  - Etcd (Embedded)
- 192.168.122.101
  - OpenShift Node (Dedicated)
- 192.168.122.199
  - OpenShift Node (Dedicated)

Total OpenShift Masters: 1
Total OpenShift Nodes: 3

NOTE: Add a total of 3 or more Masters to perform an HA installation.

Gathering information from hosts...
Traceback (most recent call last):
  File "/usr/bin/atomic-openshift-installer", line 9, in <module>
    load_entry_point('ooinstall==3.0.0', 'console_scripts', 'oo-install')()
  File "/usr/lib/python2.7/site-packages/click/core.py", line 700, in __call__
    return self.main(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/click/core.py", line 680, in main
    rv = self.invoke(ctx)
  File "/usr/lib/python2.7/site-packages/click/core.py", line 1027, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/usr/lib/python2.7/site-packages/click/core.py", line 873, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/usr/lib/python2.7/site-packages/click/core.py", line 508, in invoke
    return callback(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/click/decorators.py", line 16, in new_func
    return f(get_current_context(), *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/ooinstall/cli_installer.py", line 767, in install
    oo_cfg, callback_facts, ctx.obj['unattended'], force, verbose)
  File "/usr/lib/python2.7/site-packages/ooinstall/cli_installer.py", line 532, in get_hosts_to_run_on
    installed_hosts = get_installed_hosts(oo_cfg.hosts, callback_facts)
  File "/usr/lib/python2.7/site-packages/ooinstall/cli_installer.py", line 517, in get_installed_hosts
    if(host.connect_to in callback_facts.keys()
AttributeError: 'NoneType' object has no attribute 'keys'
Comment 1 Jason DeTiberus 2016-01-15 13:14:54 EST
This error is because no data was returned from the exec to ansible for retrieving the facts.

We have known compatibility issues with Ansible 2.0 that still need to be addressed.

That said, it should definitely fail in a nicer way than it is currently doing.
Comment 2 Eric Paris 2016-01-15 13:16:31 EST
Downgrade to ansible 1.9.4 gets past this point.
Comment 3 Samuel Munilla 2016-03-04 08:43:30 EST
https://github.com/openshift/openshift-ansible/pull/1544 open to at least catch this error condition earlier in the code.
Comment 5 Samuel Munilla 2016-08-10 14:59:24 EDT
We're up to supporting 1.9,4 and 2.x now so this should be all good now.
Comment 6 Anping Li 2016-08-10 21:18:52 EDT
The quick installer work well with ansible 2.1 now.

Note You need to log in before you can comment on or make changes to this bug.