Bug 1299088 - XPad starts automatically at login (because it provides /etc/xdg/autostart/xpad.desktop file)
Summary: XPad starts automatically at login (because it provides /etc/xdg/autostart/xp...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xpad
Version: 24
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Keywords:
Depends On:
Blocks: F24AlphaFreezeException
TreeView+ depends on / blocked
 
Reported: 2016-01-15 22:30 UTC by Giulio 'juliuxpigface'
Modified: 2016-03-25 22:20 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-03-23 16:21:17 UTC


Attachments (Terms of Use)
Screenshot taken after the login to a live session (688.58 KB, image/png)
2016-01-15 22:30 UTC, Giulio 'juliuxpigface'
no flags Details
Screenshot taken after the login to a live session (xpad's welcome window closed) (1.02 MB, image/png)
2016-01-15 22:32 UTC, Giulio 'juliuxpigface'
no flags Details
Desktop Session Settings (with Live's default settings) (193.06 KB, image/png)
2016-01-15 22:35 UTC, Giulio 'juliuxpigface'
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1517262 None None None Never

Description Giulio 'juliuxpigface' 2016-01-15 22:30:26 UTC
Created attachment 1115302 [details]
Screenshot taken after the login to a live session

Description of problem:
I don't know if this is a real issue or it's an intended behavior. However, Xpad starts automatically after the login.

The same occurs with an installed system; however, it's easy fixable disabling the autostart entry

Version-Release number of selected component (if applicable):
Fedora-Live-LXDE-x86_64-rawhide-20160115.iso

How reproducible:
Always

Steps to Reproduce:
1. Boot the current LXDE Rawhide
2. Wait until the desktop is fully loaded

Actual results:
Xpad shows up.

Expected results:
I think that Xpad should not start by default.

Additional info:
I'm attaching some screenshots.

Comment 1 Giulio 'juliuxpigface' 2016-01-15 22:32 UTC
Created attachment 1115303 [details]
Screenshot taken after the login to a live session (xpad's welcome window closed)

Comment 2 Giulio 'juliuxpigface' 2016-01-15 22:35 UTC
Created attachment 1115304 [details]
Desktop Session Settings (with Live's default settings)

Comment 3 Florian Sievert 2016-01-16 12:58:19 UTC
This seems also to occur on my KDE system and when having a xfce session. I think this somehow came with the update to xpad-4.1-6.fc23.x86_64 that was installed here on 14th of January.

Comment 4 Stephen Haffly 2016-01-25 03:06:34 UTC
This is still an issue with Fedora 23. Xpad autostarts, even though I never selected it. I don't remember even installing it. Was this pushed since it is part of the LXDE group? If so, then it needs to be removed as part of the group and moved to LXDE applications so it can be optionally installed if desired. It definitely should not autorun.

Linux 4.3.3-301.fc23.x86_64

Comment 5 Stephen Haffly 2016-01-25 03:09:22 UTC
Also, this is installed Fedora 23, not LiveCD.

Comment 6 Vasiliy Glazov 2016-02-01 07:15:09 UTC
I can confirm it. Need to remove /etc/xdg/autostart/xpad.desktop from xpad rpm.

Comment 7 Federic 2016-02-21 03:13:35 UTC
Thanks Vasiliy. That provided a quick fix until next time I update. At least I can avoid punching the screen until then. 

Why did this crufty little gadget even get included on a lightweight Fedora spin ? 

What is pulling this in? Even without the annoying autorun, I don't want it. Why is it getting pushed onto my system?

Comment 8 Giulio 'juliuxpigface' 2016-02-22 21:09:34 UTC
Basing on comments 3, 4 and 6, I'm triaging this to what seems the right component (xpad).

Comment 9 Giulio 'juliuxpigface' 2016-02-22 21:20:21 UTC
The bug has been introduced by "4.6" upstream version and seems fixed by the "4.7" one.

Comment 10 Jan Kurik 2016-02-24 15:44:24 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Comment 11 Kevin Fenzi 2016-03-05 16:36:11 UTC
Yeah, this is fixed upstream, but there's no 4.7 release yet.

I'll ask them for a release or backport the fix.

Comment 12 Federic 2016-03-05 17:53:51 UTC
This also happened on a previously installed fed23 installed from LXDE spin. 

The best solution IMO would be remove this crufty little widget from LXDE. It is just clutter on a light desktop. Hardly an essential for a lightweight system, is it? 

There is also some gadget getting installed in the task bar. I disabled it but it still keeps popping up just before disappearing again. It keeps moving my network icon an results in me clicking on something else. 

If I say I don't want it , I don't want it at all. Not I want it pop up, disrupt my workflow then disappear. 

Please remove this annoying gadget from LDXE.

Comment 13 Kevin Fenzi 2016-03-05 18:17:52 UTC
I'm just the xpad maintainer here, I have no control over what is and is not on the LXDE spin. For that I would advise some or all of the following: 

File a bug against the LXDE livecd: https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=LiveCD%20-%20LXDE

Mail the fedora lxde list: https://lists.fedoraproject.org/admin/lists/lxde.lists.fedoraproject.org/

Mail the spins list: https://lists.fedoraproject.org/admin/lists/spins.lists.fedoraproject.org/

I have no idea who is managing the LXDE spin these days.

Comment 14 Kevin Fenzi 2016-03-11 21:47:39 UTC
I talked with one of the Xpad maintainers, 1.7 is expected next week. 

Will update with the fix at that point.

Comment 15 Fedora Update System 2016-03-14 17:54:02 UTC
xpad-4.7.0-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-1f3577379b

Comment 16 Fedora Update System 2016-03-14 17:54:23 UTC
xpad-4.7.0-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-feacdae682

Comment 17 Fedora Update System 2016-03-14 17:54:44 UTC
xpad-4.7.0-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-17bac3cde2

Comment 18 Fedora Update System 2016-03-15 21:31:17 UTC
xpad-4.7.0-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-1f3577379b

Comment 19 Fedora Update System 2016-03-16 15:20:59 UTC
xpad-4.7.0-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-17bac3cde2

Comment 20 Fedora Update System 2016-03-16 15:23:50 UTC
xpad-4.7.0-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-feacdae682

Comment 21 Giulio 'juliuxpigface' 2016-03-20 20:49:12 UTC
There isn't a real criterion which has been violated. However, it would be nice to have the new version of xpad included on Fedora 24 Alpha, if possible. And if not, I'd list this bug on the CommonBugs Page, since it's easily reproducible.

I'm proposing it as Freeze Exception, since this bug has been already fixed and we won't require lots of efforts in order to push the new version to the stable repo.

Comment 22 Kamil Páral 2016-03-21 17:36:10 UTC
Discussed at today's blocker review meeting [1]. Voted as  AcceptedFreezeException - this is a visible issue on LXDE lives and cannot be fixed with an update, the fix is pretty simple and isolated, thus its accepted as a freeze exception issue

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2016-03-21

Comment 23 Fedora Update System 2016-03-23 16:21:10 UTC
xpad-4.7.0-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2016-03-25 01:25:08 UTC
xpad-4.7.0-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 25 Fedora Update System 2016-03-25 22:20:13 UTC
xpad-4.7.0-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.