Bug 1299099 - systemd, kexec: Boot failure if kdump device unavailable
systemd, kexec: Boot failure if kdump device unavailable
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kexec-tools (Show other bugs)
7.3
x86_64 Linux
high Severity medium
: rc
: 7.4
Assigned To: kdump team
Qiao Zhao
: OtherQA
Depends On:
Blocks: 1366034
  Show dependency treegraph
 
Reported: 2016-01-15 18:08 EST by George Beshers
Modified: 2016-09-29 12:27 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-29 12:27:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Beshers 2016-01-15 18:08:15 EST
Description of problem:

    We have observed that when kdump is pointed at non-root disk drive
    and later that drive is removed the kernel won't complete booting.
    [Non-root because it was on a 32TB machine and there wasn't enough
     space on the root drive.)


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Dave Young 2016-01-19 01:51:06 EST
George:

System does not boot means the normal kernel can not boot?

Have you add it to /etc/fstab or somewhere else? I guess systemd is waiting for the mount happens and timeout, is this your case and do you have a console log?

Thanks
Dave
Comment 3 George Beshers 2016-01-27 14:27:35 EST
Sorry to say that the log got deleted in a cleanup sweep.
I will work on reproducing this and provide a log.

However, the kernel booted and was doing systemd-udevd stuff
and my memory is that it was hung trying to start kdump.
That said, I've seen kdump fail to start many times without
causing the boot to hang (we get to login); so I am begining
to suspect myself of user error.
Comment 4 Russ Anderson 2016-09-22 15:22:51 EDT
Update fields so properly tracked.
Comment 5 Russ Anderson 2016-09-22 15:24:46 EDT
Not a showstopper for 7.3.
Needs additional information from George.
Comment 6 George Beshers 2016-09-29 12:27:13 EDT
Tested this with snap3 and its no longer an issue.

Note You need to log in before you can comment on or make changes to this bug.