Bug 1299123 - Admin and Config Guide: Need clarification on how to setup message size in remoting
Admin and Config Guide: Need clarification on how to setup message size in re...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.4.5
Unspecified Unspecified
unspecified Severity unspecified
: post-GA
: ---
Assigned To: David Michael
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-16 00:28 EST by Lyle Wang
Modified: 2016-10-20 15:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-20 15:13:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lyle Wang 2016-01-16 00:28:07 EST
Document URL: 
https://access.redhat.com/documentation/en-US/JBoss_Enterprise_Application_Platform/6.4/html/Administration_and_Configuration_Guide/sect-Remoting.html#Configuration_of_Message_Size_in_Remoting


Section Number and Name: 
5.4.1. Configuration of Message Size in Remoting


Describe the issue: 
Section "5.4.1. Configuration of Message Size in Remoting" talks about that we can configure "MAX_INBOUND_MESSAGE_SIZE" / "MAX_OUTBOUND_MESSAGE_SIZE" to limit the message size but does't clarify where / how to setup this.
 
Suggestions for improvement: 
Add some example config snippet, and CLI commands showing how / where to setup this MAX_INBOUND_MESSAGE_SIZE / MAX_OUTBOUND_MESSAGE_SIZE

Additional information:
Comment 1 Lyle Wang 2016-01-16 00:46:40 EST
Tested on EAP 6.4.5 it needs to be set as below in ejb3 subsystem, and the unit seems to be in byte.

--------------------------------------------
       <subsystem xmlns="urn:jboss:domain:ejb3:1.5">
......
            <remote connector-ref="remoting-connector" thread-pool-name="default">
                <channel-creation-options>
                    <option name="MAX_INBOUND_MESSAGE_SIZE" value="xxxxx" type="remoting"/>
                    <option name="MAX_OUTBOUND_MESSAGE_SIZE" value="xxxxx" type="remoting"/>
                </channel-creation-options>
            </remote>
......
        </subsystem>
--------------------------------------------

Note You need to log in before you can comment on or make changes to this bug.