Bug 129934 - crashes with AttributeError
crashes with AttributeError
Status: CLOSED DUPLICATE of bug 128967
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-samba (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-14 14:03 EDT by Kevin Krafthefer
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Krafthefer 2004-08-14 14:03:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040803

Description of problem:
On a cleanly installed and fully updated RHEL3 Desktop 
[root@localhost root]# redhat-config-samba
Traceback (most recent call last):
  File "/usr/share/redhat-config-samba/redhat-config-samba.py", line
20, in ?
    mainWindow.MainWindow(debug_flag)
  File "/usr/share/redhat-config-samba/mainWindow.py", line 58, in
__init__
    self.samba_data = sambaParser.SambaParser(self)
  File "/usr/share/redhat-config-samba/sambaParser.py", line 24, in
__init__
    self.parseFile()
  File "/usr/share/redhat-config-samba/sambaParser.py", line 55, in
parseFile
    token = self.createToken(line)
  File "/usr/share/redhat-config-samba/sambaParser.py", line 127, in
createToken    token =
sambaToken.SambaToken(sambaToken.SambaToken.SAMBA_TOKEN_KEYVAL, (name,
value), self.parent)
  File "/usr/share/redhat-config-samba/sambaToken.py", line 20, in
__init__
    raise AttributeError, value
AttributeError: ('cups options', 'raw')


Version-Release number of selected component (if applicable):
redhat-config-samba-1.0.16-1

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL3 desktop
2. Update system
3. Run redhat-config-desktop
    

Actual Results:  [root@localhost root]# redhat-config-samba
Traceback (most recent call last):
  File "/usr/share/redhat-config-samba/redhat-config-samba.py", line
20, in ?
    mainWindow.MainWindow(debug_flag)
  File "/usr/share/redhat-config-samba/mainWindow.py", line 58, in
__init__
    self.samba_data = sambaParser.SambaParser(self)
  File "/usr/share/redhat-config-samba/sambaParser.py", line 24, in
__init__
    self.parseFile()
  File "/usr/share/redhat-config-samba/sambaParser.py", line 55, in
parseFile
    token = self.createToken(line)
  File "/usr/share/redhat-config-samba/sambaParser.py", line 127, in
createToken    token =
sambaToken.SambaToken(sambaToken.SambaToken.SAMBA_TOKEN_KEYVAL, (name,
value), self.parent)
  File "/usr/share/redhat-config-samba/sambaToken.py", line 20, in
__init__
    raise AttributeError, value
AttributeError: ('cups options', 'raw')


Expected Results:  configuration gui launches

Additional info:

The is for the desktop version of RHEL3
Comment 1 Nils Philippsen 2004-08-14 14:14:24 EDT

*** This bug has been marked as a duplicate of 128967 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:07 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.