Bug 1299473 - perl-Business-PayPal-API-0.73-1.fc24 FTBFS: tests fail on bootstrap
perl-Business-PayPal-API-0.73-1.fc24 FTBFS: tests fail on bootstrap
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Business-PayPal-API (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
https://github.com/oalders/business-p...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-18 07:51 EST by Petr Pisar
Modified: 2016-01-18 08:01 EST (History)
2 users (show)

See Also:
Fixed In Version: perl-Business-PayPal-API-0.73-2.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-18 08:01:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2016-01-18 07:51:56 EST
perl-Business-PayPal-API-0.73-1.fc24 fails to build in F24 when bootstrapping:

+ make test
PERL_DL_NONLAZY=1 "/usr/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/advanced/*.t t/basic/*.t
t/advanced/ExpressCheckout.t ........ skipped: No WPP_TEST env var set. Please see README to run tests
t/advanced/ExpressOrder.t ........... skipped: No WPP_TEST env var set. Please see README to run tests
t/advanced/GetTransactionDetails.t .. skipped: No WPP_TEST env var set. Please see README to run tests
IPC::System::Simple required for Fatalised/autodying system() at t/advanced/OptionFields.t line 2.
	main::BEGIN() called at t/advanced/OptionFields.t line 2
	eval {...} called at t/advanced/OptionFields.t line 2
BEGIN failed--compilation aborted at t/advanced/OptionFields.t line 2.
t/advanced/OptionFields.t ........... 
Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/advanced/RefundTransaction.t ...... skipped: No WPP_TEST env var set. Please see README to run tests
t/advanced/TransactionSearch.t ...... skipped: No WPP_TEST env var set. Please see README to run tests
t/basic/Business-PayPal-API.t ....... ok
t/basic/DirectPayments.t ............ skipped: No WPP_TEST env var set. Please see README to run tests
t/basic/MassPay.t ................... skipped: No WPP_TEST env var set. Please see README to run tests
t/basic/RecurringPayments.t ......... skipped: No WPP_TEST env var set. Please see README to run tests
IPC::System::Simple required for Fatalised/autodying system() at t/basic/SubscriptionPayments.t line 4.
	main::BEGIN() called at t/basic/SubscriptionPayments.t line 4
	eval {...} called at t/basic/SubscriptionPayments.t line 4
BEGIN failed--compilation aborted at t/basic/SubscriptionPayments.t line 4.
t/basic/SubscriptionPayments.t ...... 
Dubious, test returned 2 (wstat 512, 0x200)

This is because the two tests use an autodie feature that requires IPC::System::Simple module that is not build-requires by the spec file.

Actually the autodie and IPC::System::Simple modules are not needed at all if the tests were written properly. See <https://github.com/oalders/business-paypal-api/issues/9>.

I will change the test to drop the useless dependencies.

Note You need to log in before you can comment on or make changes to this bug.