Bug 1299491 - VDSM memory leak
VDSM memory leak
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.5.4
Unspecified Unspecified
urgent Severity urgent
: ovirt-3.5.8
: ---
Assigned To: Francesco Romani
Eldad Marciano
: ZStream
Depends On: 1269424
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-18 08:53 EST by rhev-integ
Modified: 2016-02-29 09:50 EST (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
This release fixes a memory leak in VDSM.
Story Points: ---
Clone Of: 1269424
Environment:
Last Closed: 2016-02-29 09:50:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48287 ovirt-3.6 MERGED scheduler: use single instance 2016-01-18 08:53 EST
oVirt gerrit 51630 None None None 2016-01-18 08:53 EST
oVirt gerrit 51868 master ABANDONED misc: Fix RWLock leak due to reference cycle 2016-01-18 08:53 EST
oVirt gerrit 51917 master MERGED resourceManager: Fix ResourceRef leak 2016-01-19 10:00 EST
oVirt gerrit 52557 None None None 2016-01-22 09:29 EST
oVirt gerrit 52558 None None None 2016-01-22 09:30 EST
oVirt gerrit 52629 None None None 2016-01-25 05:46 EST
oVirt gerrit 52699 ovirt-3.5 MERGED concurrent: Introduce concurrent.thread() utility 2016-01-25 17:43 EST
oVirt gerrit 52700 ovirt-3.5 MERGED health: Introduce Vdsm health monitoring 2016-01-26 03:19 EST
oVirt gerrit 52701 ovirt-3.5 MERGED health: Report resource usage 2016-01-26 03:19 EST

  None (edit)
Comment 2 Michal Skrivanek 2016-01-18 08:58:50 EST
partial backport probably.
RWLock and virdomain leak looks like the best candidates, health monitor might be a bit too risky for 3.5.z
Comment 6 errata-xmlrpc 2016-02-29 09:50:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0317.html

Note You need to log in before you can comment on or make changes to this bug.