Bug 1299497 - Quota Aux mount crashed
Quota Aux mount crashed
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Manikandan
: ZStream
Depends On: 1294774
Blocks: 1300243
  Show dependency treegraph
 
Reported: 2016-01-18 09:07 EST by Vijaikumar Mallikarjuna
Modified: 2016-06-16 09:54 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1294774
: 1300243 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:54:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-01-18 09:08:50 EST
REVIEW: http://review.gluster.org/13254 (snapd/quota: fix aux mount with uss enabled) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Vijay Bellur 2016-01-18 13:09:13 EST
REVIEW: http://review.gluster.org/13255 (quota: start aux mount from glusterd with inet address) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 3 Vijay Bellur 2016-01-18 13:21:51 EST
REVIEW: http://review.gluster.org/13255 (quota: start aux mount from glusterd with inet address) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 4 Vijay Bellur 2016-01-19 00:24:06 EST
REVIEW: http://review.gluster.org/13255 (quota: start aux mount from glusterd with inet address) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 5 Vijay Bellur 2016-01-20 02:25:50 EST
REVIEW: http://review.gluster.org/13255 (quota: start aux mount from glusterd with inet address) posted (#4) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 6 Vijay Bellur 2016-01-20 05:20:00 EST
REVIEW: http://review.gluster.org/13255 (quota: start aux mount from glusterd with inet address) posted (#5) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 7 Vijay Bellur 2016-01-22 06:25:57 EST
COMMIT: http://review.gluster.org/13255 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit a593921aa0eada17637667938f432875b410139d
Author: vmallika <vmallika@redhat.com>
Date:   Mon Jan 18 23:31:59 2016 +0530

    quota: start aux mount from glusterd with inet address
    
    With below patches, quota aux mount now
    uses unix domain socket to connect to
    glusterd
    http://review.gluster.org/#/c/12645/
    http://review.gluster.org/#/c/12819/
    
    When USS is enabled, snapd protocol client tries to
    connect to glusterd with inet and fails,
    because remote-host option by client process
    is set to UDS file
    
    This patch starts the aux client process from glusterd
    with inet address
    
    Change-Id: I6967043bfd8824658ea39bfd2842591fcc3280fd
    BUG: 1299497
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/13255
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Comment 10 Niels de Vos 2016-06-16 09:54:41 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.