Bug 1299573 - Banshee hangs on launch, process "Main Thread" uses 100% CPU
Banshee hangs on launch, process "Main Thread" uses 100% CPU
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: banshee (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-18 11:39 EST by roger griffiths
Modified: 2016-02-26 20:20 EST (History)
6 users (show)

See Also:
Fixed In Version: banshee-2.6.2-15.fc23 banshee-2.6.2-15.fc22.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-26 14:25:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from the command: banshee --debug (deleted)
2016-01-18 11:39 EST, roger griffiths
no flags Details
output from the command: banshee --debug (19.42 KB, text/plain)
2016-01-18 11:41 EST, roger griffiths
no flags Details

  None (edit)
Description roger griffiths 2016-01-18 11:39:36 EST
Description of problem:
Launch Banshee, the Banshee Media Player window appears with nothing in the window (just a gray window). Running top, lists a process "Main Thread" using 100% of CPU. If you let the process run (at 100% CPU) for about 20 minutes then the controls and albums appear in the Banshee window and the application is functional. At that point, the "Main Thread" process stops using 100% of the CPU.

Killing the process "Main Thread" terminates Banshee.


Version-Release number of selected component (if applicable):
banshee-2.6.2-12.fc23.x86_64

I also have installed:
banshee-community-extensions-2.4.0-11.fc23.x86_64

How reproducible:
This now happens every time I launch Banshee. 
I have been using banshee for several years, but this new bug appeared suddenly last week. 

Steps to Reproduce:
1. Launch Banshee from either the menu or at the command prompt
2.
3.

Actual results:


Expected results:


Additional info:
My system is up to date ( kernel-4.3.3-300.fc23.x86_64 ). I have an AMD Phenom II X6 1055T Processor, 8 GB RAM.

The music files are on a separate drive, but other applications can access the files on the drive.

I have attached (as a file) the output from the command:
 banshee --debug
The process quickly gets to the line:
[1 Info  23:43:13.891] All services are started 0.79807
    But, the slow down seems to enter at this point, (the next line in the output):
[4 Warn  23:52:26.157] Executed in 551295ms 

There seems to be two places where there are 9 minute delays, both of these sections begin with:
     DELETE FROM CoreCache WHERE ModelID = 9;
followed by a long INSERT query (that does not seem to have a terminating ; )

Once Banshee is up, the process "Main Thread" stops consuming 100% of the CPU. However, after a short period of time playing music, a few minutes, the "Main Thread" process resumes using 100% of the CPU.

I have never seen a process named in the fashion "Main Thread" (spaces in the name and caps), I thought my system had become corrupted.
Comment 1 roger griffiths 2016-01-18 11:41 EST
Created attachment 1115897 [details]
output from the command:  banshee --debug

THis was long, so I thought it was more suitable as an attachment, is that correct?
Comment 2 alexf 2016-02-04 15:31:21 EST
Can confirm, have the same problem. We had this problem before, see bug #1161844.

Seems the fix depends on detecting the sqlite version correctly.
Comment 3 Fedora Update System 2016-02-12 15:29:23 EST
banshee-2.6.2-15.fc22.1 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a119794020
Comment 4 Fedora Update System 2016-02-12 15:29:23 EST
banshee-2.6.2-15.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5f413ccc41
Comment 5 Fedora Update System 2016-02-14 23:52:51 EST
banshee-2.6.2-15.fc22.1 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a119794020
Comment 6 Fedora Update System 2016-02-15 00:24:29 EST
banshee-2.6.2-15.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5f413ccc41
Comment 7 Fedora Update System 2016-02-26 14:25:11 EST
banshee-2.6.2-15.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2016-02-26 20:19:55 EST
banshee-2.6.2-15.fc22.1 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.