Bug 1299586 - Duplicate file association for "*.pdf"
Duplicate file association for "*.pdf"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
23
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-18 12:00 EST by David Tonhofer
Modified: 2016-02-16 22:51 EST (History)
9 users (show)

See Also:
Fixed In Version: kde-settings-23-11.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-16 22:51:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Tonhofer 2016-01-18 12:00:17 EST
Description of problem:
-----------------------

In KDE:

The filename pattern "*.pdf" appears with two file associations to "okular".

There should be only one. 

Having two makes okular appear twice when right-clicking on a PDF for example, with no clue which "okular" to take (or why)

I am entirely unsure where the dual association comes from:


Association A (first in priority)
- - - - - - - - - - - - - - - - - -

"okular"
Type: desktop configuration file
Location: /usr/share/applications/kde4
Size: 3.9 KiB (4024)
Name: Okular
Description: Document Viewer
Command: okular %U %i -caption %c
Mimetype: application/vnd.kde.okular-archive "Okular document archive"


Association B (second in priority)
- - - - - - - - - - - - - - - - - -

"okularApplication_pdf"
Type: desktop configuration file
Location: /usr/share/applications/kde4
Size: 6.5 KiB (6639)
Name: Okular
Description: Document Viewer
Command: okular %U %i -caption %c
Mimetype: application/x-wwf "WWF document"
Mimetype: application/x-gzpdf "PDF document (bzip-compressed)"
Mimetype: application/pdf "PDF document"

Association C (third in priority)
- - - - - - - - - - - - - - - - - -

Points to GIMP, which does not concern us here



(Would be a nice to have to just dump the above text description from the "Configure File Association Screen" .. I like text :-)
Comment 1 Rex Dieter 2016-02-10 13:16:18 EST
I think I found the cause of this, the default association for pdf in
/usr/share/applications/kde-mimeapps.list
is wrong.

It should refer to kde4-okularApplication_pdf.desktop instead of kde4-okular.desktop.

Working on a packaging fix...
Comment 2 Fedora Update System 2016-02-10 14:25:50 EST
kde-settings-23-11.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-46f59ae9c0
Comment 3 Fedora Update System 2016-02-11 10:21:11 EST
kde-settings-23-11.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-46f59ae9c0
Comment 4 Fedora Update System 2016-02-12 14:40:07 EST
kde-settings-23-11.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-46f59ae9c0
Comment 5 Fedora Update System 2016-02-15 00:25:05 EST
kde-settings-23-11.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-46f59ae9c0
Comment 6 Fedora Update System 2016-02-16 22:51:02 EST
kde-settings-23-11.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.