Bug 1299606 - avogadro-libs dependency issue
avogadro-libs dependency issue
Product: Fedora
Classification: Fedora
Component: avogadro (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2016-01-18 13:23 EST by Ali Akcaagac
Modified: 2016-01-30 00:29 EST (History)
3 users (show)

See Also:
Fixed In Version: avogadro-1.1.1-16.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-01-30 00:29:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ali Akcaagac 2016-01-18 13:23:44 EST
Error: Package: avogadro-libs-1.1.1-15.fc24.i686 (rawhide)
           Requires: libGLEW.so.1.10
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Please fix if possible.
Comment 1 Kevin Kofler 2016-01-19 22:38:41 EST
This is because it currently FTBFS because of some weird OpenBabel problem. I have yet to look into that.
Comment 2 Orion Poplawski 2016-01-23 10:44:18 EST
Is there some reason avogadro hasn't been updated to the avogadro 2 series?  Perhaps this would help?
Comment 3 Kevin Kofler 2016-01-24 09:44:18 EST
Kalzium needs libavogadro 1.
Comment 4 Jonathan Wakely 2016-01-28 12:29:20 EST
avogadro FTBFS with new boost in rawhide, it needs to be fixed to work with Boost 1.60

usr/include/boost/type_traits/detail/has_binary_operator.hp:50: Parse error at "BOOST_JOIN"
Comment 5 Kevin Kofler 2016-01-30 00:29:36 EST
Rex Dieter already fixed this, thanks Rex!

Note You need to log in before you can comment on or make changes to this bug.