Bug 1299650 - [abrt] python2-dnf: migrate.py:139:migrate_history_pkgs:AttributeError: 'NoneType' object has no attribute 'execute'
[abrt] python2-dnf: migrate.py:139:migrate_history_pkgs:AttributeError: 'None...
Status: CLOSED DUPLICATE of bug 1266768
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:f90dbe7219c38025f268097c866...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-18 16:50 EST by marcvw
Modified: 2016-02-27 13:25 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-19 10:16:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: _var_log_dnf.log (66.82 KB, text/plain)
2016-01-18 16:51 EST, marcvw
no flags Details
File: backtrace (1.32 KB, text/plain)
2016-01-18 16:51 EST, marcvw
no flags Details
File: dnf-makecache.log (223.57 KB, text/plain)
2016-01-18 16:51 EST, marcvw
no flags Details
File: environ (3.32 KB, text/plain)
2016-01-18 16:51 EST, marcvw
no flags Details

  None (edit)
Description marcvw 2016-01-18 16:50:53 EST
Version-Release number of selected component:
python2-dnf-1.1.5-1.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python /usr/bin/dnf-2 migrate
dso_list:       python-dnf-plugins-extras-migrate-0.0.12-1.fc23.noarch
executable:     /usr/bin/dnf-2
kernel:         4.3.3-300.fc23.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
migrate.py:139:migrate_history_pkgs:AttributeError: 'NoneType' object has no attribute 'execute'

Traceback (most recent call last):
  File "/usr/bin/dnf-2", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 174, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 60, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 112, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1095, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/migrate.py", line 117, in run
    self.migrate_history()
  File "/usr/lib/python2.7/site-packages/dnf-plugins/migrate.py", line 133, in migrate_history
    self.migrate_history_pkgs(yum_history, dnf_history)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/migrate.py", line 139, in migrate_history_pkgs
    yum_cur.execute("""
AttributeError: 'NoneType' object has no attribute 'execute'

Local variables in innermost frame:
yum_hist: <dnf.yum.history.YumHistory object at 0x7f3aefd03910>
yum_cur: None
self: <dnf.plugin.dynamic.migrate.MigrateCommand object at 0x7f3aefd03990>
dnf_hist: <dnf.yum.history.YumHistory object at 0x7f3aee6674d0>

Potential duplicate: bug 1266768
Comment 1 marcvw 2016-01-18 16:51:00 EST
Created attachment 1115981 [details]
File: _var_log_dnf.log
Comment 2 marcvw 2016-01-18 16:51:01 EST
Created attachment 1115982 [details]
File: backtrace
Comment 3 marcvw 2016-01-18 16:51:04 EST
Created attachment 1115983 [details]
File: dnf-makecache.log
Comment 4 marcvw 2016-01-18 16:51:06 EST
Created attachment 1115984 [details]
File: environ
Comment 5 Michal Domonkos 2016-01-19 10:16:16 EST

*** This bug has been marked as a duplicate of bug 1266768 ***

Note You need to log in before you can comment on or make changes to this bug.