Bug 12998 - ppp-2.3.11-4.i386.rpm (RH6.2) Peer is not authorized to use remote address xxx.xxx.xxx.xxx
Summary: ppp-2.3.11-4.i386.rpm (RH6.2) Peer is not authorized to use remote address xx...
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ppp   
(Show other bugs)
Version: 6.2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-24 20:19 UTC by youngej
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-13 09:23:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description youngej 2000-06-24 20:19:44 UTC
I justed upgraded from RH6.0 to RH6.2.  I found that I could no longer
connect to my ISP.  The solution was to go back to the ppp provide by
RH6.0.  I researched this problem at Deja.com.  There are other folks
having this problem.  This seems to occur when PAP authentication is used. 
The problem did not occur when I connected to work via a chat script.

Failure recorded in /var/log/messages:
Jun 24 15:09:41 dad pppd[1094]: pppd 2.3.11 started by root, uid 0
Jun 24 15:09:41 dad pppd[1094]: Using interface ppp0
Jun 24 15:09:41 dad pppd[1094]: Connect: ppp0 <--> /dev/ttyS2
Jun 24 15:09:48 dad pppd[1094]: Remote message: Login Succeeded
Jun 24 15:09:48 dad kernel: PPP BSD Compression module registered
Jun 24 15:09:48 dad kernel: PPP Deflate Compression module registered
Jun 24 15:09:48 dad pppd[1094]: Peer is not authorized to use remote
address 216.155.32.5
Jun 24 15:10:00 dad pppd[1094]: Connection terminated.
Jun 24 15:10:00 dad pppd[1094]: Connect time 0.2 minutes.
Jun 24 15:10:00 dad pppd[1094]: Sent 316 bytes, received 413 bytes.
Jun 24 15:10:00 dad pppd[1094]: Exit.

Same area of /var/log/messages with old package:
Jun 24 15:11:10 dad kernel: PPP: version 2.3.7 (demand dialling)
Jun 24 15:11:10 dad kernel: PPP line discipline registered.
Jun 24 15:11:10 dad kernel: registered device ppp0
Jun 24 15:11:10 dad pppd[1143]: pppd 2.3.7 started by root, uid 0
Jun 24 15:11:10 dad pppd[1143]: Using interface ppp0
Jun 24 15:11:10 dad pppd[1143]: Connect: ppp0 <--> /dev/ttyS2
Jun 24 15:11:16 dad pppd[1143]: Remote message: Login Succeeded
Jun 24 15:11:16 dad kernel: PPP BSD Compression module registered
Jun 24 15:11:16 dad kernel: PPP Deflate Compression module registered
Jun 24 15:11:16 dad pppd[1143]: local IP address 216.155.32.197
Jun 24 15:11:16 dad pppd[1143]: remote IP address 216.155.32.5

This problem happenened with both:
  vmlinuz-2.2.14-5.0
  vmlinuz-2.2.16-3
stock RedHat kernels.

Comment 1 Nalin Dahyabhai 2000-07-03 08:22:56 UTC
Which version of the "initscripts" package do you have installed?  Does adding
"noauth" to your /etc/ppp/options file help?

Comment 2 youngej 2000-07-04 17:33:12 UTC
I have the stock initscripts installed:
   initscripts-5.00-1

Putting 'noauth' into /etc/ppp/options fixes 
the problem for me.  Thanks ...

Comment 3 Thomas Woerner 2004-08-13 09:23:10 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or Fedora
Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.



Note You need to log in before you can comment on or make changes to this bug.