Bug 129983 - 2.6.7 causes external USB devices to be named differently to cdrecord
2.6.7 causes external USB devices to be named differently to cdrecord
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-16 04:59 EDT by Charles Lee
Modified: 2015-01-04 17:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-03 22:39:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Lee 2004-08-16 04:59:02 EDT
Description of problem:

USB2 CDRW worked fine with all official Fedora 2.6.6 kernels stops
working when upgrading to official Fedora 2.6.7 kernel. To be more
specific the CDRW is one I built myself using an external USB2 case
thing. The kernel now identifies the drive with the name/vendor
information of the USB to IDE bridge in the case rather than
identifying it using the CD writer name/vendor information. This
causes K3B (and I guess cdrecord upon which this relies) not to see
any CD writers on the system.


Version-Release number of selected component (if applicable):

I forget exactly (sorry)... It's the first official Fedora 2.6.7
kernel released.


How reproducible:

Always.


Steps to Reproduce:
1. Plug in external USB2 cdwriter;
2. Run K3B (or other cd writing software) and no CD writer is found.
3.
  
Actual results:

When looking at output of "cdrecord --scanbus" cdwriter is identified
by name/vendor of USB to IDE bridge.

Expected results:

When looking at output of "cdrecord --scanbus" cdwriter is identified
by name/vendor of IDE CD writer in USB drive caddy.

Additional info:

Perhaps this isn't a kernel bug and cdrecord needs updating somehow? I
put this as a kernel bug because a change in the kernel has caused the
problem.
Comment 1 Charles Lee 2004-08-25 17:49:05 EDT
Ere... Still the same (broken?) behavior with 2.6.8-1.521smp.
Comment 2 Charles Lee 2004-08-25 18:08:52 EDT
Mmmmmnnn... Just to add...

"cat /proc/sys/dev/cdrom/info" shows hda (IDE CDROM) and sr0 (USB2 CD
rewriter) under 2.6.6-1.435.2.3smp but only hda under any later FC2
kernel.

Thanks again.
Comment 3 Dave Jones 2004-11-27 17:33:30 EST
mass update for old bugs:

Is this still a problem in the 2.6.9 based kernel update ?
Comment 4 Charles Lee 2004-12-03 22:00:39 EST
I am unable to answer this as I've moved to Fedora Core 3. However, this problem
has not been present in any of the FC3 kernels since the initial release (I
didn't run the test ones).

Thanks.

Note You need to log in before you can comment on or make changes to this bug.