Bug 1299984 - prefer gpg2 over gpg
prefer gpg2 over gpg
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kgpg (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-19 11:42 EST by Christian Stadelmann
Modified: 2016-01-20 05:35 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-20 05:35:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 340676 None None None 2016-01-19 11:54 EST

  None (edit)
Description Christian Stadelmann 2016-01-19 11:42:04 EST
Description of problem:
With changes due to patch [1], kgpg prefers gpg over gpg2. Current versions of KGpg are modified to run with gpg2, not with gpg 1.x. See [2] for an example. For this reason, KGpg should prefer gpg2 over gpg 1.x or even completely rely on gpg2.

[1] https://pkgs.fedoraproject.org/cgit/rpms/kgpg.git/tree/kgpg-4.8.80-gpg2.patch 
[2] https://bugs.kde.org/show_bug.cgi?id=340676

Version-Release number of selected component (if applicable):
15.08.3-2.fc23

How reproducible:
always
Comment 1 Rex Dieter 2016-01-19 11:54:06 EST
Thanks, I'll look into it.
Comment 2 Christian Stadelmann 2016-01-20 05:35:53 EST
Hm, I deleted kgpgrc (and some other config files) and got a wizard by KGpg. It correctly preferred gpg2 over gpg. Looks like a configuration issue on my side. Sorry for the noise.

Note You need to log in before you can comment on or make changes to this bug.