Bug 1300047 - UI blows up while clicking host->Advanced Settings
UI blows up while clicking host->Advanced Settings
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Yuri Rudman
Nandini Chandra
ui:host
: ZStream
Depends On:
Blocks: 1304063
  Show dependency treegraph
 
Reported: 2016-01-19 15:11 EST by Nandini Chandra
Modified: 2016-02-13 14:42 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1304063 (view as bug list)
Environment:
Last Closed: 2016-02-11 12:17:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nandini Chandra 2016-01-19 15:11:33 EST
Description of problem:
------------------------
The UI blows up with this error while clicking the host->Advanced Settings page.

undefined method `split' for nil:NilClass [host/advanced_settings] 


Snippet from production.log:

[----] F, [2016-01-19T14:59:46.186501 #2934:f95998] FATAL -- : Error caught: [NoMethodError] undefined method `split' for nil:NilClass
/var/www/miq/vmdb/app/models/miq_report/generator.rb:57:in `col_to_expression_col'
/var/www/miq/vmdb/app/models/miq_report/search.rb:40:in `block in get_order_info'
/var/www/miq/vmdb/app/models/miq_report/search.rb:39:in `collect'
/var/www/miq/vmdb/app/models/miq_report/search.rb:39:in `get_order_info'
/var/www/miq/vmdb/app/models/miq_report/search.rb:100:in `paged_view_search'
/var/www/miq/vmdb/app/controllers/application_controller.rb:1750:in `get_view'
/var/www/miq/vmdb/app/controllers/application_controller/ci_processing.rb:541:in `show_details'
/var/www/miq/vmdb/app/controllers/application_controller/ci_processing.rb:2017:in `show_association'
/var/www/miq/vmdb/app/controllers/host_controller.rb:14:in `show_association'
/var/www/miq/vmdb/app/controllers/host_controller.rb:211:in `advanced_settings'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/implicit_render.rb:4:in `send_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/abstract_controller/base.rb:198:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/rendering.rb:10:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/abstract_controller/callbacks.rb:20:in `block in process_action'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:117:in `call'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:117:in `call'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:555:in `block (2 levels) in compile'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:505:in `call'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:505:in `call'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:92:in `__run_callbacks__'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:778:in `_run_process_action_callbacks'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:81:in `run_callbacks'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/abstract_controller/callbacks.rb:19:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/rescue.rb:29:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/instrumentation.rb:32:in `block in process_action'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/notifications.rb:164:in `block in instrument'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/notifications/instrumenter.rb:20:in `instrument'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/notifications.rb:164:in `instrument'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/instrumentation.rb:30:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/params_wrapper.rb:250:in `process_action'
/opt/rh/cfme-gemset/gems/activerecord-4.2.5/lib/active_record/railties/controller_runtime.rb:18:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/abstract_controller/base.rb:137:in `process'


Version-Release number of selected component (if applicable):
------------------
5.5.2.1


How reproducible:
----------------
Always


Steps to Reproduce:
------------------
1.Navigate to the summary page of a host.
2.From the Configuration accordion, click 'Advanced Settings'.
3.Alternatively,click Advanced Settings in the Configuration Section  in the summary page.


Actual results:
---------------
UI blows up


Expected results:
-----------------
No UI error.


Additional info:
----------------
Comment 2 Nick Carboni 2016-01-25 14:48:18 EST
Is there a test environment where this is reproducible? The "Advanced Settings" option is not clickable on every host in my dev environment.
Comment 5 Nandini Chandra 2016-02-11 12:17:30 EST
I'm unable to reproduce this issue at the moment.I'll reopen the BZ if the issue occurs again.

Note You need to log in before you can comment on or make changes to this bug.