Bug 1300075 - Maintenance SPM will cause all storage domains status to be 'unknown'
Maintenance SPM will cause all storage domains status to be 'unknown'
Status: CLOSED NOTABUG
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core (Show other bugs)
3.6.2.5
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.0.0-alpha
: ---
Assigned To: Liron Aravot
Aharon Canan
: Automation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-19 17:00 EST by Raz Tamir
Modified: 2016-05-08 04:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-28 11:17:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tnisan: ovirt‑4.0.0?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
engine log (4.19 MB, text/plain)
2016-01-19 17:00 EST, Raz Tamir
no flags Details
print screen (265.05 KB, image/png)
2016-01-19 17:02 EST, Raz Tamir
no flags Details

  None (edit)
Description Raz Tamir 2016-01-19 17:00:45 EST
Created attachment 1116399 [details]
engine log

Description of problem:
When putting the SPM host into maintenance (or even restarting the engine service), all storage domains status become unknown or a few seconds:

 DisconnectStoragePoolVDSCommandParameters:{runAsync='true', hostId='75dda0aa-22c9-427a-8a73-c4fa3adc817a', storagePoolId='860b7918-aaf3-4496-a231-70fc701364ea', vds_spm_id='1'}), log id: 1135c232
2016-01-19 23:48:33,529 INFO  [org.ovirt.engine.core.bll.storage.SetStoragePoolStatusCommand] (DefaultQuartzScheduler_Worker-15) [a07ed5a] Running command: SetStoragePoolStatusCommand internal: true. Entities affected :  ID: 860b7918-aaf3-4496-a231-70fc701364ea Type: StoragePool
2016-01-19 23:48:33,534 INFO  [org.ovirt.engine.core.vdsbroker.storage.StoragePoolDomainHelper] (DefaultQuartzScheduler_Worker-15) [a07ed5a] Storage Pool '860b7918-aaf3-4496-a231-70fc701364ea' - Updating Storage Domain 'ede2b230-cd92-4427-b3c8-6c859f2b73ee' status from 'Active' to 'Unknown', reason: null
2016-01-19 23:48:33,535 INFO  [org.ovirt.engine.core.vdsbroker.storage.StoragePoolDomainHelper] (DefaultQuartzScheduler_Worker-15) [a07ed5a] Storage Pool '860b7918-aaf3-4496-a231-70fc701364ea' - Updating Storage Domain 'bcca5423-225a-4a9a-8994-3cf8226968d1' status from 'Active' to 'Unknown', reason: null
2016-01-19 23:48:33,536 INFO  [org.ovirt.engine.core.vdsbroker.storage.StoragePoolDomainHelper] (DefaultQuartzScheduler_Worker-15) [a07ed5a] Storage Pool '860b7918-aaf3-4496-a231-70fc701364ea' - Updating Storage Domain 'e9b5e58f-0f99-4bc4-9ea5-52e2d60e668b' status from 'Active' to 'Unknown', reason: null
2016-01-19 23:48:33,537 INFO  [org.ovirt.engine.core.vdsbroker.storage.StoragePoolDomainHelper] (DefaultQuartzScheduler_Worker-15) [a07ed5a] Storage Pool '860b7918-aaf3-4496-a231-70fc701364ea' - Updating Storage Domain '3d617e2f-60e9-4b1c-9290-776210cea39b' status from 'Active' to 'Unknown', reason: null
2016-01-19 23:48:33,538 INFO  [org.ovirt.engine.core.vdsbroker.storage.StoragePoolDomainHelper] (DefaultQuartzScheduler_Worker-15) [a07ed5a] Storage Pool '860b7918-aaf3-4496-a231-70fc701364ea' - Updating Storage Domain '1af33d1d-6ece-4832-a377-5c54a96f535a' status from 'Active' to 'Unknown', reason: null
2016-01-19 23:48:33,539 INFO  [org.ovirt.engine.core.vdsbroker.storage.StoragePoolDomainHelper] (DefaultQuartzScheduler_Worker-15) [a07ed5a] Storage Pool '860b7918-aaf3-4496-a231-70fc701364ea' - Updating Storage Domain '333702e8-1c74-4bfc-a30b-fb25f2aec6dc' status from 'Active' to 'Unknown', reason: null
2016-01-19 23:48:33,540 INFO  [org.ovirt.engine.core.vdsbroker.storage.StoragePoolDomainHelper] (DefaultQuartzScheduler_Worker-15) [a07ed5a] Storage Pool '860b7918-aaf3-4496-a231-70fc701364ea' - Updating Storage Domain '4a860109-33d3-4db6-98ca-405de70e29f5' status from 'Active' to 'Unknown', reason: null
2016-01-19 23:48:33,541 INFO  [org.ovirt.engine.core.vdsbroker.storage.StoragePoolDomainHelper] (DefaultQuartzScheduler_Worker-15) [a07ed5a] Storage Pool '860b7918-aaf3-4496-a231-70fc701364ea' - Updating Storage Domain '57daa5ae-2d13-442a-a9da-8fd969430fec' status from 'Active' to 'Unknown', reason: null
2016-01-19 23:48:33,542 INFO  [org.ovirt.engine.core.vdsbroker.storage.StoragePoolDomainHelper] (DefaultQuartzScheduler_Worker-15) [a07ed5a] Storage Pool '860b7918-aaf3-4496-a231-70fc701364ea' - Updating Storage Domain '908f372a-7302-428e-b601-a8a1b0630d50' status from 'Active' to 'Unknown', reason: null
2016-01-19 23:48:33,543 INFO  [org.ovirt.engine.core.vdsbroker.storage.StoragePoolDomainHelper] (DefaultQuartzScheduler_Worker-15) [a07ed5a] Storage Pool '860b7918-aaf3-4496-a231-70fc701364ea' - Updating Storage Domain '649e8c64-eae8-44d3-9e94-9be12eb8fac9' status from 'Active' to 'Unknown', reason: null
2016-01-19 23:48:33,635 WARN  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (DefaultQuartzScheduler_Worker-15) [a07ed5a] Correlation ID: a07ed5a, Call Stack: null, Custom Event ID: -1, Message: Invalid status on Data Center golden_env_mixed. Setting status to Non Responsive.




Version-Release number of selected component (if applicable):
rhevm-3.6.2.5-0.1.el6.noarch
vdsm-4.17.17-0.el7ev.noarch


How reproducible:
100%

Steps to Reproduce:
1. Put SPM host into maintenance
2.
3.

Actual results:
All storage domains status become unknown


Expected results:


Additional info:
Comment 1 Raz Tamir 2016-01-19 17:02 EST
Created attachment 1116401 [details]
print screen

If extra logs needed, let me know
Comment 2 Raz Tamir 2016-01-20 04:28:00 EST
Setting the severity to medium because I don't see real impact on the customer
Comment 3 Tal Nisan 2016-01-20 11:12:01 EST
Liron, I think this is the expected behavior, isn't it?
Comment 4 Allon Mureinik 2016-03-28 11:17:50 EDT
(In reply to Tal Nisan from comment #3)
> Liron, I think this is the expected behavior, isn't it?
Yes.

Note You need to log in before you can comment on or make changes to this bug.