Bug 130010 - Bad class created by ecj in ant
Bad class created by ecj in ant
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ecj (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Gary Benson
:
: 126491 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-16 11:55 EDT by Gary Benson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-03 05:13:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Benson 2004-08-16 11:55:05 EDT
Description of problem:
Ecj incorrectly compiles one of ant's tasks, causing gcj to emit the
following error when compiling the bytecode to native:

org/apache/tools/ant/taskdefs/FixCRLF.java: In class
`org.apache.tools.ant.taskdefs.FixCRLF':
org/apache/tools/ant/taskdefs/FixCRLF.java: In method
`org.apache.tools.ant.taskdefs.FixCRLF.processFile(java.lang.String)':
org/apache/tools/ant/taskdefs/FixCRLF.java:366: error: verification
error at PC=659
org/apache/tools/ant/taskdefs/FixCRLF.java:366: error: might transfer
control into subroutine
e

Version-Release number of selected component (if applicable):
ecj-2.1.3-5

Additional info:
This is not bug 129323.
Comment 1 Gary Benson 2004-09-08 06:59:57 EDT
*** Bug 126491 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.