Bug 130019 - RFE: make xlib/xwem even more quiet, compress info files
RFE: make xlib/xwem even more quiet, compress info files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xemacs-sumo (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-16 12:30 EDT by Ville Skyttä
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 20040818-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 18:58:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Make xlib/xwem even quieter, compress and 'dir'ify info files (2.59 KB, patch)
2004-08-16 12:31 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2004-08-16 12:30:44 EDT
Here's a patch for the xemacs-sumo specfile, it uses the pre-released
xlib and xwem packages to make the startup warnings even more quiet,
and adds stuff to compress and dir'ify info files for lower disk space
consumption when installed, and better "M-x info" (from within XEmacs)
experience as a non-root user.

I think it's ok to pre-generate the "dir" files for info files as long
as they're in the XEmacs Sumo "private" info directories, but in the
future maybe they (c|s)hould be installed into /usr/share/info...?
Comment 1 Ville Skyttä 2004-08-16 12:31:49 EDT
Created attachment 102765 [details]
Make xlib/xwem even quieter, compress and 'dir'ify info files
Comment 2 Jens Petersen 2004-08-16 21:18:41 EDT
Thanks for the patch: I like the info improvements. :-)
Adding that to the next build.

Installing sumo info files (in fact xemacs info files too)
in the central info dir is problematic because of clashes with info
files from Emacs, etc. (Well the XEmacs ones currently taken care of
by removing the info, standards and termcap manuals - not
a big deal.)  I just tried installing all the sumo manuals
in the central dir file and there were "clashes" with gnus
and ediff for example to name a few: the problem being two-fold
if the info Entry's are the same then if say the xemacs-sumo-info
is uninstalled, the emacs Entry may be removed too, and even if
the Entry's are distinguished, it is only possible to reach the
one in the global info directory anyway from the dir file afaict:
so I think your current solution is actually pretty optimal.
(Not many people read xemacs sumo info manuals outside XEmacs I guess.)

I'm a bit less sure about updating xwem, since I had
more problems when actually using xwem-1.14-pkg than the released
version...  but I guess not that many people are using it though. :)

Do you still see output from xlib/xwem with the current sumo package?
Comment 3 Ville Skyttä 2004-08-17 02:21:27 EDT
Regarding the xwem version, I admit I do not use it at all.  The patch
that went into it in the current pre-releases for fixing the autoload
breakage (== the startup messages) is a very big one.  The same
applies to xlib too (and I don't personally use that either).

Perhaps it's possible to fix this by patching xwem/xlib instead of 
updating them, but with xemacs-sumo-20040517-3 I see this at startup
in the "*Warnings*" buffer:

(1) (warning/warning) Autoload error in:
/usr/share/xemacs/xemacs-packages/lisp/xwem/auto-autoloads:
	Symbol's function definition is void: Xmask-or

With "my" 20040517-4, no warnings are shown at startup here.
Comment 4 Jens Petersen 2004-08-17 07:57:00 EDT
Yes, you're right - thanks for spotting that.

Ok, I'll add the newer xlib and xwem too to fix it properly. :)
Comment 5 Jens Petersen 2004-08-17 08:12:33 EDT
Your fixes are in 20040517-4.

Do you think there will be another sumo update soon?
It would be nice before fc3t2. :)
Comment 6 Ville Skyttä 2004-08-17 16:50:35 EDT
I talked to Norbert, and got the impression that new Sumos will be out
either this week, or on the 2nd week of September; probably the
former... had I known that I would not have started doing the
xlib/xwem hacks, sorry :(
Comment 7 Jens Petersen 2004-08-18 22:47:40 EDT
No worries. The new sumos should be in the next rawhide push. :)
Comment 8 Warren Togami 2004-08-24 18:20:18 EDT
Is this done?
Comment 9 Ville Skyttä 2004-08-24 18:58:06 EDT
Yep, thanks.

Note You need to log in before you can comment on or make changes to this bug.