Bug 1300215 - [fork][userinterface_public_576]Always show Creating on next step page
[fork][userinterface_public_576]Always show Creating on next step page
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Management Console (Show other bugs)
3.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: bpeterse
yapei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-20 04:51 EST by yapei
Modified: 2016-05-12 13:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 13:11:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
CreatingOnNextStepPage (12.05 KB, image/png)
2016-01-20 04:52 EST, yapei
no flags Details
MessageOnOverviewPage (40.64 KB, image/png)
2016-01-20 04:53 EST, yapei
no flags Details
HTTPMessageError (32.46 KB, image/png)
2016-01-20 05:00 EST, yapei
no flags Details

  None (edit)
Description yapei 2016-01-20 04:51:20 EST
Description of problem:
When create dc and hpa using a template includes different api groups, message "Creating <template_name> in project <project_name>" and "Creating" are always on the next step page. there is no helpful info on next page. When click project name it goes back to project overview, we could find resources are created successfully, but we can't clear the message on overview page
 
Version-Release number of selected component (if applicable):
fork_ami_openshift3_userinterface_public_576_177 

How reproducible:
Always

Steps to Reproduce:
1.cat test-template.yaml
kind: Template
apiVersion: v1
metadata:
  annotations:
    description: This example shows create HPA
    iconClass: icon-ruby
    tags: hpa
  creationTimestamp: null
  name: hpa-scale
objects:
- apiVersion: v1
  kind: DeploymentConfig
  metadata:
    labels:
      run: php-apache
    name: php-apache
  spec:
    replicas: 1
    selector:
      run: php-apache
    template:
      metadata:
        labels:
          run: php-apache
      spec:
        containers:
        - image: gcr.io/google_containers/hpa-example
          imagePullPolicy: IfNotPresent
          name: php-apache
          resources:
            requests:
              cpu: 200m
          securityContext:
            privileged: true
        restartPolicy: Always
        securityContext: {}
        terminationGracePeriodSeconds: 30
    triggers:
    - type: ConfigChange
- apiVersion: extensions/v1beta1
  kind: HorizontalPodAutoscaler
  metadata:
    name: php-apache
  spec:
    scaleRef:
      kind: DeploymentConfig
      name: php-apache
      subresource: scale
    minReplicas: 1
    maxReplicas: 10
    cpuUtilization:
      targetPercentage: 50
2.create template via CLI
# oc create -f test-template.yaml
template "hpa-scale" created
3. create hpa and dc from template on web console

Actual results:
"Creating" message are showing all the time, no other useful info, message on overview page could not be cleared(see attachment)

Expected results:
Should create dc and hpa successfully, show instructions of CLI and link to overview page

Additional info:
create resource from template via command line succeed
# oc create -f test-template.yaml
template "hpa-scale" created
# oc process hpa-scale | oc create -f -
deploymentconfig "php-apache" created
horizontalpodautoscaler "php-apache" created
Comment 1 yapei 2016-01-20 04:52 EST
Created attachment 1116561 [details]
CreatingOnNextStepPage
Comment 2 yapei 2016-01-20 04:53 EST
Created attachment 1116564 [details]
MessageOnOverviewPage
Comment 3 yapei 2016-01-20 05:00 EST
Created attachment 1116568 [details]
HTTPMessageError
Comment 4 bpeterse 2016-01-22 13:53:59 EST
I have not been able to reproduce this. Is there any missing information in your #3 creating hpa and dc from template on web console?  Please elaborate, thanks!
Comment 5 bpeterse 2016-01-22 15:37:30 EST
needed to adjust to the following:
oc create -f test-template.yaml -n openshift 

to create the template in the openshift namespace.
Comment 6 bpeterse 2016-01-22 15:38:20 EST
I believe this is resolved.  I will be creating a new fork_ami, comment will be on the trello card.
Comment 7 yapei 2016-01-24 07:14:43 EST

(In reply to bpeterse from comment #5)
> needed to adjust to the following:
> oc create -f test-template.yaml -n openshift 
> 
> to create the template in the openshift namespace.

create template in other namespace also reproduce this issue, anyway since this has been resolved, I will verify in new fork_ami
Comment 8 yapei 2016-01-25 20:48:36 EST
tested on fork_ami_openshift3_userinterface_public_576_193, resources in test-template.yaml are all created successfully

Note You need to log in before you can comment on or make changes to this bug.