Bug 1300232 - numanodes tag did not work right
numanodes tag did not work right
Status: CLOSED NOTABUG
Product: Beaker
Classification: Community
Component: general (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: beaker-dev-list
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-20 05:18 EST by Wayne Sun
Modified: 2016-02-03 00:34 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-03 00:34:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wayne Sun 2016-01-20 05:18:07 EST
Description of problem:
numanodes tag not working right

Version-Release number of selected component (if applicable):
beaker-client-22.0-2.el7sed.noarch

How reproducible:
always

Steps to Reproduce:
1. submit a job with numanodes in job
# bkr workflow-simple --hostrequire="numanodes >= 2" --debug --distro="RHEL-7.2-20151030.0" --task="/distribution/dummy" --prettyxml --arch="x86_64"
<job retention_tag="Scratch">
	<whiteboard></whiteboard>
	<recipeSet priority="Normal">
		<recipe ks_meta="" whiteboard="">
			<distroRequires>
				<and>
					<distro_name op="=" value="RHEL-7.2-20151030.0"/>
					<distro_arch op="=" value="x86_64"/>
				</and>
			</distroRequires>
			<hostRequires>
				<and>
					<numanodes op="&gt;=" value="2"/>
				</and>
			</hostRequires>
			<repos/>
			<partitions/>
			<task name="/distribution/install" role="STANDALONE">
				<params/>
			</task>
			<task name="/distribution/dummy" role="STANDALONE">
				<params/>
			</task>
		</recipe>
	</recipeSet>
</job>

Submitted: ['J:1196383']


2. check beaker job
the machine got is only with 1 numa node
3.

Actual results:
numanodes did not work

Expected results:
should work

Additional info:
Comment 1 Roman Joost 2016-01-20 21:50:28 EST
Thanks for your report.

Looks like there is a mistake in the hostrequires paramater. You can request either by:

  --hostrequire '<system><numanodes ..></system'

which is the recommended way or by:

  --hostrequire 'numa_node_count >= 2'

which is deprecated but still works.

Would you mind to confirm?
Comment 2 Wayne Sun 2016-01-20 22:35:57 EST
(In reply to Roman Joost from comment #1)
> Thanks for your report.
> 
> Looks like there is a mistake in the hostrequires paramater. You can request
> either by:
> 
>   --hostrequire '<system><numanodes ..></system'
> 
> which is the recommended way or by:
> 
>   --hostrequire 'numa_node_count >= 2'
> 
> which is deprecated but still works.
> 
> Would you mind to confirm?

Both way you mentioned are working:

# bkr workflow-simple --hostrequire="<system><numanodes op='&gt;=' value='2'/></system>" --debug --distro="RHEL-7.2-20151030.0" --task="/distribution/dummy" --prettyxml --arch="x86_64"
<job retention_tag="Scratch">
	<whiteboard></whiteboard>
	<recipeSet priority="Normal">
		<recipe ks_meta="" whiteboard="">
			<distroRequires>
				<and>
					<distro_name op="=" value="RHEL-7.2-20151030.0"/>
					<distro_arch op="=" value="x86_64"/>
				</and>
			</distroRequires>
			<hostRequires>
				<and>
					<system>
						<numanodes op="&gt;=" value="2"/>
					</system>
				</and>
			</hostRequires>
			<repos/>
			<partitions/>
			<task name="/distribution/install" role="STANDALONE">
				<params/>
			</task>
			<task name="/distribution/dummy" role="STANDALONE">
				<params/>
			</task>
		</recipe>
	</recipeSet>
</job>

Submitted: ['J:1197584']


# bkr workflow-simple --hostrequire='numa_node_count >= 2' --debug --distro="RHEL-7.2-20151030.0" --task="/distribution/dummy" --prettyxml --arch="x86_64"
<job retention_tag="Scratch">
	<whiteboard></whiteboard>
	<recipeSet priority="Normal">
		<recipe ks_meta="" whiteboard="">
			<distroRequires>
				<and>
					<distro_name op="=" value="RHEL-7.2-20151030.0"/>
					<distro_arch op="=" value="x86_64"/>
				</and>
			</distroRequires>
			<hostRequires>
				<and>
					<numa_node_count op="&gt;=" value="2"/>
				</and>
			</hostRequires>
			<repos/>
			<partitions/>
			<task name="/distribution/install" role="STANDALONE">
				<params/>
			</task>
			<task name="/distribution/dummy" role="STANDALONE">
				<params/>
			</task>
		</recipe>
	</recipeSet>
</job>

Submitted: ['J:1197586']

So the problem is --hostrequire="numanodes >= 2" used to work but not working now.
Comment 3 Dan Callaghan 2016-01-24 20:02:15 EST
(In reply to Wayne Sun from comment #2)
> So the problem is --hostrequire="numanodes >= 2" used to work but not
> working now.

Are you sure that has ever worked? What Beaker versions did you see it work/stop working?

Maybe you were using it and by coincidence it was giving you machines with more than 1 NUMA node even though the filter was having no effect?

We introduced the <numanodes/> filter, which must be enclosed in <system/>, in Beaker 0.10.1:

https://git.beaker-project.org/cgit/beaker/commit/?id=12cb295834a207629862b88efa53f0b342a07abe

Prior to that the only supported filter was <numa_node_count/>.
Comment 4 Wayne Sun 2016-01-31 15:52:45 EST
(In reply to Dan Callaghan from comment #3)
> (In reply to Wayne Sun from comment #2)
> > So the problem is --hostrequire="numanodes >= 2" used to work but not
> > working now.
> 
> Are you sure that has ever worked? What Beaker versions did you see it
> work/stop working?
> 
> Maybe you were using it and by coincidence it was giving you machines with
> more than 1 NUMA node even though the filter was having no effect?
> 
> We introduced the <numanodes/> filter, which must be enclosed in <system/>,
> in Beaker 0.10.1:
> 
> https://git.beaker-project.org/cgit/beaker/commit/
> ?id=12cb295834a207629862b88efa53f0b342a07abe
> 
> Prior to that the only supported filter was <numa_node_count/>.

Ok, got it. Thanks for clarify this, I think this could be closed as NOTABUG now.

Note You need to log in before you can comment on or make changes to this bug.