Bug 130026 - mod_jk2 uri mappings do not appear to work
mod_jk2 uri mappings do not appear to work
Status: CLOSED NOTABUG
Product: Red Hat Application Server
Classification: Retired
Component: mod_jk2 (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Permaine Cheung
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-16 13:18 EDT by Cott Lang
Modified: 2007-04-18 13:10 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-16 14:37:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cott Lang 2004-08-16 13:18:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040803 Firefox/0.9.3

Description of problem:
I've been using mod_jk2 for a while in FC2, specifically
mod_jk2-4.1.27-13. It works fine.

I tried installing mod_jk2-2.0.4-4jpp_4rh from RHAS on some WS3
machines, and the uri mappings do not appear to work correctly,
despite no changes in the mappings.  All I've tried to do is get the
Tomcat admin servlet to work:

[uri:/admin/*]
info=Admin

It appears that a call to /admin/ correctly maps over to Tomcat, but
most (!) subpaths do not, ie, the main page comes up but the images
map elsewhere.

Replacing mod_jk2.so with the one from mod_jk2-4.1.27-13 gets
everything working again.  

Looking at CHANGES.txt, it appears that this is an unreleased version
of mod_jk2, whereas the mod_jk2-4.1.27 I'm using is actually rev 2.0.4.

Version-Release number of selected component (if applicable):
2.0.4-4jpp_4rh

How reproducible:
Always

Steps to Reproduce:
1. try to map a uri to the admin servlet.
2. 
3.
    

Additional info:
Comment 1 Permaine Cheung 2004-08-16 14:37:59 EDT
Hi Cott,

Please modify your uri mapping to:

[uri:$/admin/*]
info=Admin

With the $, the regular expression that comes after it will be parsed
properly and all subpaths will map correctly.

Please note that this is listed in the release notes on the beta 2
website as well: 
http://people.redhat.com/patrickm/rhaps-beta2/rhapsrelnotes.htm


Cheers,
Permaine
Comment 2 Cott Lang 2004-08-20 13:37:43 EDT
Thanks for the response on this.

However, I wasn't part of the beta and the url you gave doesn't work. :)

I just added the channel and installed the release. I can't find any
mention of this in the docs, and the sample workers2.properties has
the old style in it.  I really think someone should consider
documenting this and fixing the example, it would be very helpful. :)

Comment 3 Permaine Cheung 2004-08-20 13:52:18 EDT
We had just moved the beta website, and the release note can now be
found at:

http://people.redhat.com/patrickm/rhaps-beta2/archive/rhapsrelnotes.htm

Our next release of mod_jk2 will have that fixed. :)

Note You need to log in before you can comment on or make changes to this bug.