Bug 1300322 - [abrt] virt-manager: adapters.py:20:<module>:ImportError: cannot import name select_proxy
[abrt] virt-manager: adapters.py:20:<module>:ImportError: cannot import name ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:9e8f60855f4fd56d1b067374744...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-20 08:26 EST by Allan Poulsen
Modified: 2016-01-20 10:16 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-20 10:16:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (7.65 KB, text/plain)
2016-01-20 08:26 EST, Allan Poulsen
no flags Details
File: environ (2.48 KB, text/plain)
2016-01-20 08:26 EST, Allan Poulsen
no flags Details

  None (edit)
Description Allan Poulsen 2016-01-20 08:26:25 EST
Version-Release number of selected component:
virt-manager-1.3.2-1.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python2 -tt /usr/share/virt-manager/virt-manager
dso_list:       virt-manager-common-1.3.2-1.fc23.noarch
executable:     /usr/share/virt-manager/virt-manager
kernel:         4.3.3-300.fc23.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
#1 <module> in /usr/lib/python2.7/site-packages/requests/adapters.py:20
#2 <module> in /usr/lib/python2.7/site-packages/requests/sessions.py:27
#3 <module> in /usr/lib/python2.7/site-packages/requests/api.py:14
#4 <module> in /usr/lib/python2.7/site-packages/requests/__init__.py:60
#5 <module> in /usr/share/virt-manager/virtinst/urlfetcher.py:27
#6 <module> in /usr/share/virt-manager/virtinst/distroinstaller.py:26
#7 <module> in /usr/share/virt-manager/virtinst/__init__.py:87
#8 <module> in /usr/share/virt-manager/virt-manager:34
Comment 1 Allan Poulsen 2016-01-20 08:26:34 EST
Created attachment 1116656 [details]
File: backtrace
Comment 2 Allan Poulsen 2016-01-20 08:26:36 EST
Created attachment 1116657 [details]
File: environ
Comment 3 Cole Robinson 2016-01-20 10:14:11 EST
What does the output of this command give?

python -c 'import requests; print requests'


If that fails, you probably have a different or stale version of python-requests installed somewhere, probably via pip. Try 'sudo dnf reinstall python-requests'
Comment 4 Allan Poulsen 2016-01-20 10:15:43 EST
Closed as this failure occurred because of errors in the installed python packages. Somehow the requests package was not cleanly installed.
Comment 5 Allan Poulsen 2016-01-20 10:16:21 EST
python -c 'import requests; print requests'
<module 'requests' from 'requests/__init__.pyc'>

Note You need to log in before you can comment on or make changes to this bug.