Bug 1300381 - inconsistency between command-line 'dnf' and software updates in system tray
inconsistency between command-line 'dnf' and software updates in system tray
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-20 10:48 EST by Stefan Seefeld
Modified: 2016-01-25 07:56 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-25 07:56:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Seefeld 2016-01-20 10:48:46 EST
I regularly find inconsistency between the "software updates" tool that displays updates in the system tray, and the command-line 'dnf' tool.

For example, right now the 'software updates' tool informs me of one available update, but then running `dnf update` in a terminal informs me about "Nothing to do."
Comment 1 Michal Domonkos 2016-01-25 07:56:19 EST
Since dnf maintains its own cache, you may be seeing this discrepancy due to the dnf cache not being up-to-date.  Running "dnf update --refresh" will refresh the cache before resolving the updates so you should then see the same list of updates as the software updates tool (packagekit).

I'm closing this now.  If you continue seeing this issue even when using the --refresh option, please feel free to reopen it.

Note You need to log in before you can comment on or make changes to this bug.