Bug 1300425 - [RFE][manila] Consistency Groups (being replaced by Generic Share Groups)
[RFE][manila] Consistency Groups (being replaced by Generic Share Groups)
Status: CLOSED UPSTREAM
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-manila (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: ---
: 12.0 (Pike)
Assigned To: Tom Barron
Dustin Schoenbrun
Don Domingo
https://blueprints.launchpad.net/mani...
: FutureFeature, TechPreview, TestOnly, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-20 13:41 EST by Sean Cohen
Modified: 2017-05-15 10:54 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Technology Preview
Doc Text:
With the Manila service, you can now create shares within Consistency Groups to guarantee snapshot consistency across multiple shares. Driver vendors must report this capability and implement its functions to work according to the back end. This feature is not recommended for production cloud environments, as it is still in its experimental stage.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-23 11:51:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 219891 None None None 2016-01-20 13:41 EST

  None (edit)
Description Sean Cohen 2016-01-20 13:41:22 EST
Consistency groups are a mechanism to allow multiple filesystem shares to be guaranteed snapshots are able to be created at the exact same point in time. For example, a database may have its tables, logs, and configuration on separate volumes. If we wanted to restore the database from a previous point in time, it would only make sense to restore the logs, tables, and configuration together from the exact same point in time. 


Full spec can be found at: https://wiki.openstack.org/wiki/Manila/design/manila-liberty-consistency-groups
Comment 3 Mike McCune 2016-03-28 19:38:32 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Andrew Dahms 2016-03-30 21:12:21 EDT
The doc text for this bug has been incorporated into the formal Technology Preview section, and does not need to be collected from this bug.

Changing 'requires_doc_text' to '-'.
Comment 7 Sean Cohen 2016-09-23 11:51:50 EDT
Adding Manila share groups spec:
Comment 8 Tom Barron 2017-02-08 08:18:48 EST
Consistency Group API was replaced by Generic Share Group API in ocata but implementation and testing of generic share groups is rolling over into pike.  ConsistencyGroups and Generic Share Groups are Experimental API features - i.e., their REST headers indicate that they are Experimental and that is advertised to mean that the API can change or even be eliminated (as happened with Consistency Groups) in future releases.

I am moving the target release to Pike as that is the very earliest that this experimental feature will be available and testable.
Comment 9 Lucy Bopf 2017-05-15 02:08:52 EDT
(In reply to Tom Barron from comment #8)
> Consistency Group API was replaced by Generic Share Group API in ocata but
> implementation and testing of generic share groups is rolling over into
> pike.  ConsistencyGroups and Generic Share Groups are Experimental API
> features - i.e., their REST headers indicate that they are Experimental and
> that is advertised to mean that the API can change or even be eliminated (as
> happened with Consistency Groups) in future releases.
> 
> I am moving the target release to Pike as that is the very earliest that
> this experimental feature will be available and testable.

Hi Tom,

The text in the 'Doc Text' field is currently set to be included in the RHOSP 11 Release Notes, because the bug is still flagged for rhos-11.0.

Should the release flag also be moved to rhos-12.0?

Note You need to log in before you can comment on or make changes to this bug.