Bug 1300502 - rhel-osp-director: IPV6 HA deployment with VXLAN: failed neutron pcs resources.
rhel-osp-director: IPV6 HA deployment with VXLAN: failed neutron pcs resources.
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity high
: y3
: 7.0 (Kilo)
Assigned To: chris alfonso
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-20 20:55 EST by Alexander Chuzhoy
Modified: 2016-04-18 02:58 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-26 13:07:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs from a controller (4.10 MB, application/x-gzip)
2016-01-20 21:08 EST, Alexander Chuzhoy
no flags Details

  None (edit)
Description Alexander Chuzhoy 2016-01-20 20:55:26 EST
rhel-osp-director: IPV6 deployment failed neutron pcs resources.

Environment:
openstack-neutron-bigswitch-lldp-2015.1.38-1.el7ost.noarch
python-neutronclient-2.4.0-2.el7ost.noarch
python-neutron-2015.1.2-6.el7ost.noarch
openstack-neutron-2015.1.2-6.el7ost.noarch
python-neutron-lbaas-2015.1.2-1.el7ost.noarch
openstack-neutron-lbaas-2015.1.2-1.el7ost.noarch
openstack-neutron-common-2015.1.2-6.el7ost.noarch
openstack-neutron-ml2-2015.1.2-6.el7ost.noarch
openstack-neutron-metering-agent-2015.1.2-6.el7ost.noarch
openstack-neutron-openvswitch-2015.1.2-6.el7ost.noarch
instack-undercloud-2.1.2-37.el7ost.noarch
openstack-tripleo-heat-templates-0.8.6-110.el7ost.noarch


Steps to reproduce:
Successfully deploy HA overcloud with IPv6.
Login to any controller and check the pcs resources.

Result:
[root@overcloud-controller-0 ~]# pcs status|grep -B1 -i stop
 Clone Set: neutron-l3-agent-clone [neutron-l3-agent]
     Stopped: [ overcloud-controller-0 overcloud-controller-1 overcloud-controller-2 ]
--
 Clone Set: neutron-metadata-agent-clone [neutron-metadata-agent]
     Stopped: [ overcloud-controller-0 overcloud-controller-1 overcloud-controller-2 ]
--
 Clone Set: neutron-dhcp-agent-clone [neutron-dhcp-agent]
     Stopped: [ overcloud-controller-0 overcloud-controller-1 overcloud-controller-2 ]
--
 Clone Set: neutron-openvswitch-agent-clone [neutron-openvswitch-agent]
     Stopped: [ overcloud-controller-0 overcloud-controller-1 overcloud-controller-2 ]



Expected result:
no failures.

This is the content of /var/log/neutron/openvswitch-agent.log:
2016-01-20 19:57:33.408 26031 CRITICAL neutron [-] ConfigFileValueError: fd00:fd00:fd00:5000:f816:3eff:fe62:1cc0 is not an IPv4 address
2016-01-20 19:57:33.408 26031 TRACE neutron Traceback (most recent call last):
2016-01-20 19:57:33.408 26031 TRACE neutron   File "/usr/bin/neutron-openvswitch-agent", line 10, in <module>
2016-01-20 19:57:33.408 26031 TRACE neutron     sys.exit(main())
2016-01-20 19:57:33.408 26031 TRACE neutron   File "/usr/lib/python2.7/site-packages/neutron/cmd/eventlet/plugins/ovs_neutron_agent.py", line 20, in main
2016-01-20 19:57:33.408 26031 TRACE neutron     ovs_neutron_agent.main()
2016-01-20 19:57:33.408 26031 TRACE neutron   File "/usr/lib/python2.7/site-packages/neutron/plugins/openvswitch/agent/ovs_neutron_agent.py", line 1736, in main
2016-01-20 19:57:33.408 26031 TRACE neutron     q_utils.log_opt_values(LOG)
2016-01-20 19:57:33.408 26031 TRACE neutron   File "/usr/lib/python2.7/site-packages/neutron/common/utils.py", line 270, in log_opt_values
2016-01-20 19:57:33.408 26031 TRACE neutron     cfg.CONF.log_opt_values(log, std_logging.DEBUG)
2016-01-20 19:57:33.408 26031 TRACE neutron   File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 2199, in log_opt_values
2016-01-20 19:57:33.408 26031 TRACE neutron     _sanitize(opt, getattr(group_attr, opt_name)))
2016-01-20 19:57:33.408 26031 TRACE neutron   File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 2520, in __getattr__
2016-01-20 19:57:33.408 26031 TRACE neutron     return self._conf._get(name, self._group)
2016-01-20 19:57:33.408 26031 TRACE neutron   File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 2242, in _get
2016-01-20 19:57:33.408 26031 TRACE neutron     value = self._do_get(name, group, namespace)
2016-01-20 19:57:33.408 26031 TRACE neutron   File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 2283, in _do_get
2016-01-20 19:57:33.408 26031 TRACE neutron     raise ConfigFileValueError(str(ve))
2016-01-20 19:57:33.408 26031 TRACE neutron ConfigFileValueError: fd00:fd00:fd00:5000:f816:3eff:fe62:1cc0 is not an IPv4 address
2016-01-20 19:57:33.408 26031 TRACE neutron
Comment 2 Alexander Chuzhoy 2016-01-20 21:08 EST
Created attachment 1116762 [details]
logs from a controller
Comment 3 Angus Thomas 2016-01-26 13:07:12 EST
VXLAN is not supported with IPv6 in OpenStack Neutron Kilo.
Please read: http://openvswitch.org/pipermail/discuss/2015-January/016344.html

Only VLAN mode can be used for now.
Also see: https://bugs.launchpad.net/neutron/+bug/1531660

So this is not a bug.

Note You need to log in before you can comment on or make changes to this bug.