Bug 1300603 - ld reports .eh_frame_hdr TABLE overlaps while testing whether relocation are not truncated
ld reports .eh_frame_hdr TABLE overlaps while testing whether relocation are ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: binutils (Show other bugs)
7.3
aarch64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Nick Clifton
Miloš Prchlík
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-21 04:28 EST by Miloš Prchlík
Modified: 2018-02-08 05:08 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: When an application is linked, it is possible for it to contain duplicate blocks of information describing how to unwind the stack. (Called FDE or Frame Description Entry) Consequence: These duplicates, although not harmful, would cause the linker to emit error messages about overlaps in the .eh_frame_hdr table. Fix: Add code to the linker to detect and ignore duplicate FDE entries. Result: No more spurious error messages from the linker.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-02-08 02:35:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Ignore duplicate FDE entries (796 bytes, patch)
2016-02-10 09:09 EST, Nick Clifton
no flags Details | Diff

  None (edit)
Comment 1 Nick Clifton 2016-02-09 12:20:30 EST
This appears to have been fixed upstream:

  https://sourceware.org/bugzilla/show_bug.cgi?id=17467

testing now...
Comment 2 Nick Clifton 2016-02-09 12:44:30 EST
Nope - that patch has already been applied to the sources.  Back to the drawing board...
Comment 3 Nick Clifton 2016-02-10 09:09 EST
Created attachment 1122796 [details]
Ignore duplicate FDE entries

This patch will solve the problem.

Well maybe solve is not quite the correct word.  The problem is not that there
are overlapping FDE entries, but rather there are *duplicate* FDE entries.  The
patch works around this by just suppressing the overlap warning for the duplicates but really the correct solution would be to eliminate them altogether.  This requires a more extensive change and one that I do not feel comfortable doing without more discussion on the binutils mailing list.

The reason that this problem has come up now is that the code to check for overlapping FDE entries was not present in earlier binutils releases.
Comment 4 Nick Clifton 2016-04-13 10:00:26 EDT
Patch applied.
Comment 5 John Feeney 2018-01-26 12:08:27 EST
I am trying to clean up old AArch64 bugzillas and came across this.

What can we do to get this VERIFIED and CLOSED? 

Thanks.
Comment 6 Miloš Prchlík 2018-01-29 03:05:59 EST
My guess is the bug, while fixed, fell under the table and wasn't added to the 7.3 erratum :( I'm not really sure what process we should follow now, I'm open to suggestions - the issue is gone, either fixed by the patch in the case of 7.3 (test runs for 7.3 builds, binutils-2.25.1-*, are clear), or by rebases in 7.4, 7.5 and Alt.
Comment 7 Martin Cermak 2018-01-31 07:08:03 EST
I think it's late to add this to a released erratum.  Milos, please, indicate the bug is fixed by flipping to VERIFIED (+ filling in the fixed in field) and the, if noone objects, we can close this one out.

Matt, does, the above plan sound good to you?
Comment 10 Miloš Prchlík 2018-02-08 02:34:09 EST
The bug was uncovered by a regression test for another bug, and AFAICT it's been fixed correctly (comment #4) as the corresponding test passed several test runs following the problematic one. Despite not being a part of the erratum, I believe it's been verified.
Comment 11 Miloš Prchlík 2018-02-08 02:35:20 EST
And closing, as it's too late to change erratum that's been already shipped in RHEL-7.3 days.
Comment 12 Martin Cermak 2018-02-08 05:08:05 EST
Thanks, Milos.

Note You need to log in before you can comment on or make changes to this bug.