Bug 1300666 - Performance profile for RHEL for SAP HANA
Performance profile for RHEL for SAP HANA
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned (Show other bugs)
7.2
noarch Linux
high Severity high
: rc
: ---
Assigned To: Jaroslav Škarvada
qe-baseos-daemons
:
Depends On:
Blocks: 1018952
  Show dependency treegraph
 
Reported: 2016-01-21 06:51 EST by jblume@redhat.com
Modified: 2016-01-26 10:49 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Performance profile for RHEL for SAP HANA Reason: Tune RHEL7 performance for SAP HANA Result: Tuned operating environment
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-26 10:49:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
First draft of a performance profile for SAP HANA. Rewritten for RHEL7 based of the one for RHEL6. (696 bytes, text/plain)
2016-01-21 06:51 EST, jblume@redhat.com
no flags Details

  None (edit)
Description jblume@redhat.com 2016-01-21 06:51:08 EST
Created attachment 1116919 [details]
First draft of a performance profile for SAP HANA. Rewritten for RHEL7 based of the one for RHEL6.

Description of problem:
RHEL7.2 for SAP HANA is expected to be certified within the next weeks. But there is still a performance profile missing to maximize the performance when SAP HANA is run on RHEL7.2 as it is already for RHEL6.

Steps to Reproduce:
1. Try to tune your system with # tuned-adm profile sap-hana
2. The attempt will fail due to missing profile

Actual results:
Profile sap-hana missing and not yet available

Expected results:
Availability inside a future RHEL7.2 for SAP HANA channel

Additional info:
See attachment /etc/tuned/sap-hana/tuned.conf
Comment 2 Jeremy Eder 2016-01-21 07:56:52 EST
Hi Jurgen, thanks for sending this!  Some comments inline -- 

#
# tuned configuration for SAP HANA
# Written by: jblume@redhat.com
#
[main]
include=throughput-performance

[cpu]
force_latency=1

[vm]
transparent_hugepages=never

[disk]
readahead_multiply=4

Hmm, we still have this in tuned, but the rest of the profiles moved away from readahead_multiply in RHEL7.  It got quite complicated to ensure that readahead values were as expected during profile rollback/forward and disk hotplug.  So we went with a static-ish value.  The throughput-performance profile which this profile includes, sets 

[disk]
readahead=>4096

Which means that it will ensure that readahead is always 4096 or larger.  If the user sets it manually to anything larger than 4096, tuned will leave it alone.  So, I would request that you also move to this method, and if 4096 works for SAP, then perhaps drop the [disk] section entirely?

[sysctl]
# If a workload mostly uses anonymous memory and it hits this limit, the entire
# working set is buffered for I/O, and any more write buffering would require
# swapping, so it's time to throttle writes until I/O can catch up.  Workloads
# that mostly use file mappings may be able to use even higher values.
#
# The generator of dirty data starts writeback at this percentage (system default
# is 20%)

I see you copied this blurb from throughput-performance.  I'd probably just drop the comment entirely.  Upstream default is 20, but RHEL default is 40.  And this profile sets vm.dirty_ratio=10.

vm.dirty_ratio = 10

[bootloader]
cmdline=intel.idle_max_cstate=1 processor.max_cstate=1

This is redundant as you've set force_latency=1.  You can drop the bootloader thing and still get the same performance/behavior.
Comment 3 Jaroslav Škarvada 2016-01-22 06:08:02 EST
There are already some SAP profiles in RHEL-7 (all bits from RHEL-6 should be there) [1], [2]. Is this profile different from them? How should be this profile named and in which sub-package should it be delivered?

[1] https://brewweb.devel.redhat.com/rpminfo?rpmID=4119732
[2] https://brewweb.devel.redhat.com/rpminfo?rpmID=4119734
Comment 4 Frank Danapfel 2016-01-26 09:54:07 EST
Here's the old bugzilla requesting the tuned-sap-hana package for RHEL7 which was resolved for RHEL7.2: https://bugzilla.redhat.com/show_bug.cgi?id=1246642
Comment 5 Jaroslav Škarvada 2016-01-26 09:56:20 EST
(In reply to Frank Danapfel from comment #4)
> Here's the old bugzilla requesting the tuned-sap-hana package for RHEL7
> which was resolved for RHEL7.2:
> https://bugzilla.redhat.com/show_bug.cgi?id=1246642

Is this request for addition of new profile? Or edit of the existing SAP profiles? Or should be this bug closed as already resolved?

Note You need to log in before you can comment on or make changes to this bug.