Bug 13007 - GUI upgrade problem with Trident 3DImage 9750
GUI upgrade problem with Trident 3DImage 9750
Status: CLOSED DUPLICATE of bug 15453
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
: 13149 (view as bug list)
Depends On:
Blocks: 13149
  Show dependency treegraph
 
Reported: 2000-06-24 19:27 EDT by Henri Schlereth
Modified: 2007-03-26 23:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-16 16:06:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henri Schlereth 2000-06-24 19:27:29 EDT
Machine P100 64MB/PCI
Video Trident 3DImage 9750
Compaq SVGA
6 GB Quantum HD
4 GB IBM HD
IDE ZIP Drive
32X Compaq Cd-rom
1x Sony CDu33a
SB16/DSP
3c503 NIC
Dual Boot RH6.2/Win95
(note: this not a compaq machine, it just has some scavenged compaq parts)

The installer booted up into the GUI and promptly began doing the
video earthquake/lambada. If I could strap myself into a paint mixer and
get it to synch with the monitor I likely could have continued.
I will try to do a text mode after my eyes settle down again.

Mind now, this does work with RH62 and X and windoze.

Henri

P.S. backed up my rpm database files this time. :)
Comment 1 Henri Schlereth 2000-06-30 23:24:29 EDT
Additional tests.
I have managed to persuade X to start at 1024x768 8bpp. Gnome starts fine
KDE crashes, and XCFE locks keyboard/screen up hard on shutdown. The
configuration file comments out the 4 MB of memory.
Any value below or above the given number either results in blur/shaking
or Xconfigurator fails.
I tested both the xfce I had 3.3.2.1 amd the one from the powertools CD
(I believe identical versions)
Comment 2 Henri Schlereth 2000-07-01 00:37:49 EDT
Final addendum:
After I made sure all symlinks to X were identical in both /usr/X11R6/bin
and /etc/X11, and made sure XFree86 was suid root, now non-root users
can run X.
Additionally I changed the settings under Xconfigurator to 800x600, let
it claim there was a problem and just quit instead of back. Viola
despite the so called problem 800x600. Not a very satisfying prosect for
Joe Customer to deal with but at least these are clues provided.

Xfce 3.3.3.1 is totally hosed still. Click on any icon and it goes to
lock-up land. Symptoms are open box(blank) and croak.
I dont have an answer for that one.
Comment 3 Glen Foster 2000-07-18 15:28:59 EDT
This defect is considered MUST-FIX for Winston Beta-5
Comment 4 Erik Troan 2000-07-21 12:52:27 EDT
*** Bug 13149 has been marked as a duplicate of this bug. ***
Comment 5 Glen Foster 2000-07-21 14:40:49 EDT
Does this defect still exist with (on) Winston beta-4?
Comment 6 Henri Schlereth 2000-07-21 15:04:38 EDT
Cant answer to Beta4, I dont have the bandwidth to do an rpm download in a reasonable time-frame.
Comment 7 Michael Fulbright 2000-07-27 14:37:23 EDT
Is this fixed in beta 5?
Comment 8 Emmanuel Galanos 2000-08-04 09:55:16 EDT
Beta5 does not fix this bug. The effect I see seems a bit different, but
basically it makes it impossible to do a GUI install.
Comment 9 Henri Schlereth 2000-08-04 18:17:07 EDT
Beta5 GUI crashes on me, still unresolved issue.
Comment 10 Matt Wilson 2000-08-04 18:58:58 EDT
whatd does the crash look like?
Comment 11 Henri Schlereth 2000-08-08 17:28:26 EDT
Sorry for the delay, in Beta5 aka Pinstripe it crashes prior to the switchover to GUI, either anaconda or sig11. I will try to re-create
it tonight. This machine will install RH6.1 just fine but nothing after that. If I do a manual RPM everything will work if tediously.
It takes an average of 1 day straight or 2 1/2 days liesurely to do a full bore shotgun upgrade(everything).
Comment 12 Henri Schlereth 2000-08-16 16:06:54 EDT
As of RC5 the GUI no longer crashes but instead becomes an etch-a-sketch. This is actually an improvement of sorts.
Amazingly when I went back and did a text upgrade it went all the way thru. This machine hasnt allowed me to do
anything but a manual rpm since after RH6.1. This is major progress for this boxen. The etch-a-sketch problem goes away
when I re-install the XFree86-SVGA-20 version from RH6.2. Dont know what to say about that, but that's how I "fix" it.
A reversion isnt that bad if you have it available.

Henri
Comment 13 Bill Nottingham 2000-08-16 23:50:59 EDT

*** This bug has been marked as a duplicate of 15453 ***

Note You need to log in before you can comment on or make changes to this bug.