Bug 1300831 - SELinux is preventing plugin-containe from 'write' accesses on the directory sys.
SELinux is preventing plugin-containe from 'write' accesses on the directory ...
Status: CLOSED DUPLICATE of bug 1300833
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2016-01-21 16:44 EST by Jan Kowalski
Modified: 2016-01-25 02:32 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-01-25 02:32:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jan Kowalski 2016-01-21 16:44:22 EST
Description of problem:
SELinux is preventing plugin-containe from 'write' accesses on the directory sys.

*****  Plugin mozplugger (99.1 confidence) suggests   ************************

If you want to use the plugin package
Then należy wyłączyć kontrolę SELinuksa nad wtyczkami Firefoksa.
# setsebool -P unconfined_mozilla_plugin_transition 0

*****  Plugin catchall (1.81 confidence) suggests   **************************

If aby plugin-containe powinno mieć domyślnie write dostęp do sys directory.
Then proszę to zgłosić jako błąd.
Można utworzyć lokalny moduł polityki, aby umożliwić ten dostęp.
można tymczasowo zezwolić na ten dostęp wykonując polecenia:
# grep plugin-containe /var/log/audit/audit.log | audit2allow -M mojapolityka
# semodule -i mojapolityka.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
Target Context                unconfined_u:object_r:home_root_t:s0
Target Objects                sys [ dir ]
Source                        plugin-containe
Source Path                   plugin-containe
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           filesystem-3.2-35.fc23.x86_64
Policy RPM                    selinux-policy-3.13.1-158.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.3.3-300.fc23.x86_64 #1 SMP Tue
                              Jan 5 23:31:01 UTC 2016 x86_64 x86_64
Alert Count                   546
First Seen                    2016-01-21 20:48:40 CET
Last Seen                     2016-01-21 22:43:21 CET
Local ID                      34775341-24da-492b-9614-1871e06d960d

Raw Audit Messages
type=AVC msg=audit(1453412601.335:1332): avc:  denied  { write } for  pid=8733 comm="plugin-containe" name="sys" dev="dm-2" ino=652850 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:home_root_t:s0 tclass=dir permissive=0

Hash: plugin-containe,mozilla_plugin_t,home_root_t,dir,write

Version-Release number of selected component:

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.3.3-300.fc23.x86_64
type:           libreport

Potential duplicate: bug 834835
Comment 1 Miroslav Grepl 2016-01-25 02:32:47 EST

*** This bug has been marked as a duplicate of bug 1300833 ***

Note You need to log in before you can comment on or make changes to this bug.