Bug 1300833 - SELinux is preventing plugin-containe from 'getattr' accesses on the file /home/admin/.macromedia/Flash_Player/macromedia.com/support/flashplayer/sys/settings.sol.
SELinux is preventing plugin-containe from 'getattr' accesses on the file /ho...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
x86_64 Unspecified
low Severity low
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:5e722ba63bcfd27b3177d51ad3c...
:
: 1300831 1300834 1300835 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-21 16:45 EST by Jan Kowalski
Modified: 2016-01-25 02:34 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-25 02:34:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kowalski 2016-01-21 16:45:43 EST
Description of problem:
SELinux is preventing plugin-containe from 'getattr' accesses on the file /home/admin/.macromedia/Flash_Player/macromedia.com/support/flashplayer/sys/settings.sol.

*****  Plugin restorecon (57.3 confidence) suggests   ************************

If aby naprawić etykietę. 
domyślna etykieta /home/admin/.macromedia/Flash_Player/macromedia.com/support/flashplayer/sys/settings.sol powinna wynosić mozilla_home_t.
Then można wykonać polecenie restorecon.
Do
# /sbin/restorecon -v /home/admin/.macromedia/Flash_Player/macromedia.com/support/flashplayer/sys/settings.sol

*****  Plugin mozplugger (43.1 confidence) suggests   ************************

If you want to use the plugin package
Then należy wyłączyć kontrolę SELinuksa nad wtyczkami Firefoksa.
Do
# setsebool -P unconfined_mozilla_plugin_transition 0

*****  Plugin catchall (1.06 confidence) suggests   **************************

If aby plugin-containe powinno mieć domyślnie getattr dostęp do settings.sol file.
Then proszę to zgłosić jako błąd.
Można utworzyć lokalny moduł polityki, aby umożliwić ten dostęp.
Do
można tymczasowo zezwolić na ten dostęp wykonując polecenia:
# grep plugin-containe /var/log/audit/audit.log | audit2allow -M mojapolityka
# semodule -i mojapolityka.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
                              0.c1023
Target Context                unconfined_u:object_r:home_root_t:s0
Target Objects                /home/admin/.macromedia/Flash_Player/macromedia.co
                              m/support/flashplayer/sys/settings.sol [ file ]
Source                        plugin-containe
Source Path                   plugin-containe
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-158.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.3.3-300.fc23.x86_64 #1 SMP Tue
                              Jan 5 23:31:01 UTC 2016 x86_64 x86_64
Alert Count                   121
First Seen                    2016-01-21 20:48:39 CET
Last Seen                     2016-01-21 22:43:21 CET
Local ID                      66deda2e-a39a-4d6d-bb48-1653158c8a1d

Raw Audit Messages
type=AVC msg=audit(1453412601.330:1318): avc:  denied  { getattr } for  pid=8733 comm="plugin-containe" path="/home/admin/.macromedia/Flash_Player/macromedia.com/support/flashplayer/sys/settings.sol" dev="dm-2" ino=652863 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:home_root_t:s0 tclass=file permissive=0


Hash: plugin-containe,mozilla_plugin_t,home_root_t,file,getattr

Version-Release number of selected component:
selinux-policy-3.13.1-158.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.3.3-300.fc23.x86_64
type:           libreport

Potential duplicate: bug 1046097
Comment 1 Miroslav Grepl 2016-01-25 02:32:47 EST
*** Bug 1300831 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2016-01-25 02:32:54 EST
*** Bug 1300834 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Grepl 2016-01-25 02:33:00 EST
*** Bug 1300835 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Grepl 2016-01-25 02:34:39 EST
Could you please try to execute

/sbin/restorecon -R -v /home/admin/.macromedia

to fix labeling for this directory? It should fix this problem. 

Thank you.

Note You need to log in before you can comment on or make changes to this bug.