Bug 1300835 - SELinux is preventing plugin-containe from 'read' accesses on the file cert9.db.
SELinux is preventing plugin-containe from 'read' accesses on the file cert9.db.
Status: CLOSED DUPLICATE of bug 1300833
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2016-01-21 16:47 EST by Jan Kowalski
Modified: 2016-01-25 02:33 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-01-25 02:33:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jan Kowalski 2016-01-21 16:47:01 EST
Description of problem:
SELinux is preventing plugin-containe from 'read' accesses on the file cert9.db.

*****  Plugin mozplugger (99.1 confidence) suggests   ************************

If you want to use the plugin package
Then należy wyłączyć kontrolę SELinuksa nad wtyczkami Firefoksa.
# setsebool -P unconfined_mozilla_plugin_transition 0

*****  Plugin catchall (1.81 confidence) suggests   **************************

If aby plugin-containe powinno mieć domyślnie read dostęp do cert9.db file.
Then proszę to zgłosić jako błąd.
Można utworzyć lokalny moduł polityki, aby umożliwić ten dostęp.
można tymczasowo zezwolić na ten dostęp wykonując polecenia:
# grep plugin-containe /var/log/audit/audit.log | audit2allow -M mojapolityka
# semodule -i mojapolityka.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
Target Context                unconfined_u:object_r:home_root_t:s0
Target Objects                cert9.db [ file ]
Source                        plugin-containe
Source Path                   plugin-containe
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-158.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.3.3-300.fc23.x86_64 #1 SMP Tue
                              Jan 5 23:31:01 UTC 2016 x86_64 x86_64
Alert Count                   60
First Seen                    2016-01-21 20:48:39 CET
Last Seen                     2016-01-21 22:42:35 CET
Local ID                      eb7f1518-2184-4f29-83cf-d727eda7bdfd

Raw Audit Messages
type=AVC msg=audit(1453412555.975:1282): avc:  denied  { read } for  pid=8733 comm="plugin-containe" name="cert9.db" dev="dm-2" ino=652812 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:home_root_t:s0 tclass=file permissive=0

Hash: plugin-containe,mozilla_plugin_t,home_root_t,file,read

Version-Release number of selected component:

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.3.3-300.fc23.x86_64
type:           libreport

Potential duplicate: bug 977199
Comment 1 Miroslav Grepl 2016-01-25 02:33:00 EST

*** This bug has been marked as a duplicate of bug 1300833 ***

Note You need to log in before you can comment on or make changes to this bug.