Bug 1300920 - /dashboard/admin/metering page in horizon doesn't work
/dashboard/admin/metering page in horizon doesn't work
Status: CLOSED CANTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity high
: ---
: 7.0 (Kilo)
Assigned To: Matthias Runge
Ido Ovadia
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-21 23:56 EST by Graeme Gillies
Modified: 2016-02-11 05:01 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-11 05:01:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graeme Gillies 2016-01-21 23:56:16 EST
When using horizon on a moderately loaded RHOS 7.0.3 installation, if you browse to the url

http://openstack.example.com/dashboard/admin/metering/

the page sits there taking forever to load, eventually timing out with a 504 error.

This 504 error is coming from haproxy which has a hard limit set to time out pages that take longer than 1 minute to load.

The underlying issue looks like this page and the way it interacts with ceilometer is simply sub par.
Comment 3 Oded Ramraz 2016-02-11 04:52:04 EST
Raising the priority / severity as it affecting our internal central CI environment.

Note You need to log in before you can comment on or make changes to this bug.