Bug 1301016 - Unable to save forms in PDF
Summary: Unable to save forms in PDF
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: poppler
Version: 23
Hardware: All
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-22 10:47 UTC by Juanjo
Modified: 2016-12-20 18:04 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-20 18:04:09 UTC
Type: Bug


Attachments (Terms of Use)
Sample form that is not saved (106.50 KB, application/pdf)
2016-01-22 10:47 UTC, Juanjo
no flags Details


Links
System ID Private Priority Status Summary Last Updated
FreeDesktop.org 93882 0 None None None 2016-01-27 10:46:54 UTC

Description Juanjo 2016-01-22 10:47:51 UTC
Created attachment 1117146 [details]
Sample form that is not saved

Description of problem:
I am unable to fill in a PDF form and save it. This complicates the workflow in our company, where these documents are used to collect employees' information about travels, expense authorizations, money orders, etc


Version-Release number of selected component (if applicable):


How reproducible:
Systematic

Steps to Reproduce:
1.Open a PDF with a form
2.Fill in data in the form
3.Click on save a copy: data is lost

Alternatively:
1.Open a PDF with a form
2.Fill in data in the form
3.Click on open a copy
4.Press Ctrl-S to save
5.Data is lost

Actual results:
The PDF is saved with empty fields.

Expected results:
The PDF should be saved with the current values of the fields

Additional info:
The only workaround I know is to *print* the PDF but this destroys the purpose of these forms and their electronic processing.

Comment 1 Marek Kašík 2016-01-26 15:53:00 UTC
Hi Juanjo,

I've found the problem but the solution is not easy. The problem is that xref table of the PDF file is fragmented into 2 consecutive tables with a hole between them and when poppler tries to read through it it encounters the hole and tries to reconstruct the xref table (I'm still not sure whetehr it is because of the hole or because of a different problem). It rewrites the changes in this moment. I'm still not sure how to fix this but in the meantime converting the PDF by qpdf makes the saving work again (e.g. "qpdf in.pdf out.pdf").

Regards

Marek

Comment 2 Marek Kašík 2016-01-27 10:46:55 UTC
I've posted my findings to upstream bugzilla. See https://bugs.freedesktop.org/show_bug.cgi?id=93882 for additional info.

Comment 3 Fedora Admin XMLRPC Client 2016-10-14 08:07:20 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 4 Fedora End Of Life 2016-11-24 15:06:30 UTC
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 5 Fedora End Of Life 2016-12-20 18:04:09 UTC
Fedora 23 changed to end-of-life (EOL) status on 2016-12-20. Fedora 23 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.