Bug 1301059 - NetworkManager is not reliably starting ethernet interface [NEEDINFO]
NetworkManager is not reliably starting ethernet interface
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager (Show other bugs)
7.2
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Rashid Khan
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-22 08:22 EST by Fani Orestiadou
Modified: 2016-01-22 22:36 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-22 14:44:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
bgalvani: needinfo? (forestia)


Attachments (Terms of Use)

  None (edit)
Description Fani Orestiadou 2016-01-22 08:22:54 EST
Description of problem:
When ethernet interface is handled by NetworkManager, sometimes after reboot interfaces has no IP assigned, and needs to be started manually.
This situation is not observed on every reboot, but when NM_CONTROLLED=no defined under ifcfg-script issue is not present any more.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux Server release 7.2 (Maipo)
3.10.0-327.3.1.el7.x86_64 

How reproducible: Configure the interface to be handled by NetworkManager and reboot.


Steps to Reproduce:
1.
2.
3.

Actual results: Sometimes interface is not started and needs to be started manually


Expected results: Active interface with IP address assigned


Additional info: When the issue is visible, after the reboot 
IP
  Interface  Master IF  MAC Address        MTU     State  IPv4 Address
  =========  =========  =================  ======  =====  ==================
  lo         -          -                  65536   up     127.0.0.1/8
  ens192     -          00:50:56:9c:6f:96  1500    up     10.0.0.85/30
  ens224     -          00:50:56:9c:61:c2  1500    up     -     <----

]# cat etc/sysconfig/network-scripts/ifcfg-ens192 
TYPE=Ethernet
BOOTPROTO=none
DEFROUTE=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=no
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_FAILURE_FATAL=no
NAME=ens192
UUID=29fc7fbd-8ca9-4aac-93ed-637e49e4e5a2
DEVICE=ens192
ONBOOT=yes
DNS1=10.170.3.5
DNS2=10.170.3.8
DOMAIN=gulfairco.loc
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes
IPV6_PRIVACY=no
IPADDR=10.170.29.65
PREFIX=24
GATEWAY=10.170.29.1


]# cat etc/sysconfig/network-scripts/ifcfg-ens224 
TYPE=Ethernet
BOOTPROTO=none
IPADDR=10.0.0.85
PREFIX=30
DEFROUTE=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes
IPV6_FAILURE_FATAL=no
NAME=ens224
UUID=cd372633-0cb8-416c-b5fa-1bb3623cfbdf
ONBOOT=yes
Comment 2 Beniamino Galvani 2016-01-22 08:38:28 EST
(In reply to Fani Orestiadou from comment #0)
> ]# cat etc/sysconfig/network-scripts/ifcfg-ens224 
> TYPE=Ethernet
> BOOTPROTO=none
> IPADDR=10.0.0.85
> PREFIX=30
> DEFROUTE=yes
> IPV4_FAILURE_FATAL=no
> IPV6INIT=yes
> IPV6_AUTOCONF=yes
> IPV6_DEFROUTE=yes
> IPV6_PEERDNS=yes
> IPV6_PEERROUTES=yes
> IPV6_FAILURE_FATAL=no
> NAME=ens224
> UUID=cd372633-0cb8-416c-b5fa-1bb3623cfbdf
> ONBOOT=yes

This connection is not bound to any device and so NM is allowed to activate it on any ethernet interface. When the issue happens it's because NM is activating the connection on the wrong one.

I think that adding DEVICE=ens224 to the file (or using the HWADDR property) should fix the issue.

Note You need to log in before you can comment on or make changes to this bug.