Bug 130109 - incorrect build prerequires string
incorrect build prerequires string
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-17 04:45 EDT by Andy Shevchenko
Modified: 2015-01-04 17:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-10 20:19:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andy Shevchenko 2004-08-17 04:45:25 EDT
Description of problem:
New kernel packages (such as 2.6.7 from updates) has incorrect
BuildPreReq parameters about kernel-utils.

Kernel-utils has following versio/release pair:
Version:        2.4
Release:        9.%(R="$Revision: 1.131 $"; RR="${R##: }"; echo ${RR%%?})

and serial:
Serial:         1

But in kernel-2.6.7-1.494.2.2 I have found next requirement:
BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg,
kernel-utils >= 2.4-12.1.139

where I have not found anything about Serial/Epoch.

I think this primitive bug could be fixed.
Comment 1 Arjan van de Ven 2004-08-17 05:00:35 EDT
hmmmmm indeed
I've fixed this now for the next build
thanks for the report.
Comment 2 Andy Shevchenko 2004-08-17 08:57:19 EDT
Ok, thanks.
And good idea to issue kernel-utils update for FC2 as I consider.

Note You need to log in before you can comment on or make changes to this bug.