This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1301119 - Upgrade from 7.1GA to 7.3 puddle fails with timeout
Upgrade from 7.1GA to 7.3 puddle fails with timeout
Status: CLOSED WORKSFORME
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
x86_64 Linux
unspecified Severity high
: y3
: 7.0 (Kilo)
Assigned To: chris alfonso
yeylon@redhat.com
:
: 1301117 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-22 11:09 EST by Dan Yasny
Modified: 2016-04-18 03:11 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 16:56:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
deployments dump (279.58 KB, text/plain)
2016-01-22 11:10 EST, Dan Yasny
no flags Details

  None (edit)
Description Dan Yasny 2016-01-22 11:09:41 EST
Description of problem:
Upgrade of a simple virt environment to the Jan 20 2016 puddle fails with timeout. Deployment shows missing network components 

Version-Release number of selected component (if applicable):
[stack@instack ~]$ rpm -qa |grep tripleo
openstack-tripleo-image-elements-0.9.6-10.el7ost.noarch
openstack-tripleo-heat-templates-0.8.6-110.el7ost.noarch
openstack-tripleo-puppet-elements-0.0.1-5.el7ost.noarch
openstack-tripleo-common-0.0.1.dev6-5.git49b57eb.el7ost.noarch
openstack-tripleo-0.0.7-0.1.1664e566.el7ost.noarch
[stack@instack ~]$ rpm -qa |grep instack
instack-0.0.7-2.el7ost.noarch
instack-undercloud-2.1.2-37.el7ost.noarch

[stack@instack ~]$ rhos-release -L
Installed repositories (rhel-7.2):
  7-director
  7
  rhel-7.2
[stack@instack ~]$ rhos-release -v
1.0.25


How reproducible:
consistent

Steps to Reproduce:
 Network isolation is enabled.
 Deployment command: openstack overcloud deploy --templates --control-scale 3 --compute-scale 2    --neutron-network-type vxlan --neutron-tunnel-types vxlan  --ntp-server 10.5.26.10 --timeout 90 -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e network-environment.yaml

Update command: yes ""|openstack overcloud update stack overcloud -i --templates -e /usr/share/openstack-tripleo-heat-templates/overcloud-resource-registry-puppet.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/updates/update-from-vip.yaml -e network-environment.yaml -e custom.yaml


Actual results:
stack_status_reason   | Timed out

Expected results:
Updated overcloud

Additional info:

Attaching the deployment dump ([stack@instack ~]$ for i in $(heat resource-list --nested-depth 5 overcloud | grep FAILED |cut -d'|' -f3); do echo DEPL: $i; heat deployment-show $i; done > deployments.txt)
Comment 2 Dan Yasny 2016-01-22 11:10 EST
Created attachment 1117286 [details]
deployments dump
Comment 3 Mike Burns 2016-01-22 11:22:42 EST
*** Bug 1301117 has been marked as a duplicate of this bug. ***
Comment 4 James Slagle 2016-01-27 09:59:22 EST
the error from the deployments is from yum:

[Errno 256] No more mirrors to try

makes sure your nodes have working dns and can download packages from their configured yum repos.
Comment 6 Dan Yasny 2016-01-27 16:02:47 EST
Just tested with latest puddle, upgrade worked fine.

Note You need to log in before you can comment on or make changes to this bug.