This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 130115 - bash3 broke functions with a dash in the name
bash3 broke functions with a dash in the name
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Stein
Ben Levenson
http://www.aplit.org/damien/gpgsig/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-17 05:26 EDT by Brian Stein
Modified: 2013-03-01 00:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-17 05:31:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arjan van de Ven 2004-08-17 05:26:45 EDT
Description of problem:
function echo-head ()
{
    echo "        gpgsig $VERSION"
    echo "        ----------"
    echo
}


used to work with old bash, now it doesn't anymore with bash 3
Comment 1 Arjan van de Ven 2004-08-17 05:27:47 EDT
http://www.aplit.org/damien/gpgsig/ is the script in question
Comment 2 Tim Waugh 2004-08-17 05:29:00 EDT
This fragment works fine.
Comment 3 Tim Waugh 2004-08-17 05:31:19 EDT
Script works for me with 3.0-4.

Note You need to log in before you can comment on or make changes to this bug.