Bug 1301334 - windows 2008 VM run once with sysprep, tries to load from network first.
windows 2008 VM run once with sysprep, tries to load from network first.
Status: CLOSED NOTABUG
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core (Show other bugs)
3.6.2
Unspecified Unspecified
unspecified Severity high (vote)
: ---
: ---
Assigned To: nobody nobody
Ilanit Stein
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-24 05:39 EST by Ilanit Stein
Modified: 2016-02-14 03:41 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-14 03:41:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
istein: planning_ack?
istein: devel_ack?
istein: testing_ack?


Attachments (Terms of Use)
engine log (relevant part is from 2016-02-03 13:48) (385.83 KB, application/x-gzip)
2016-02-03 09:20 EST, Ilanit Stein
no flags Details

  None (edit)
Description Ilanit Stein 2016-01-24 05:39:14 EST
Description of problem:
For a VM created from a sealed windows 2008 template.
The VM has a network interface.
Run once with floppy attached, [sysprep],
comes up with trying to load from network, then from disk, and fail to boot.

When removing the nic. Same Run once loads with sysprep, and works just fine (run over the values, by defined in the run once initial run dialog).   

Version-Release number of selected component (if applicable):


How reproducible:
always

Expected results:
guest should come up with setup by the sysprep attached to it's floppy.

Additional info:
The sealed template was created from a VM created with windows 2008 attach disk.
and then followed the windows 2008 sealing procedure from rhev Virtual_Machine_Management_Guide
Comment 1 Ilanit Stein 2016-01-24 09:18:01 EST
same happens with windows 2008 R2 (with same flow).
Comment 2 Tomas Jelinek 2016-02-03 05:06:25 EST
could you please attach the engine logs for the relevant part?
Comment 3 Ilanit Stein 2016-02-03 09:20 EST
Created attachment 1120793 [details]
engine log (relevant part is from 2016-02-03 13:48)
Comment 4 Ilanit Stein 2016-02-03 09:22:36 EST
Comment on attachment 1120793 [details]
engine log (relevant part is from 2016-02-03 13:48)

The engine.log, starting 2016-02-03 13:48,
contain all steps from create VM from win 2008 R2, then fail to boot from network, disk, and eventually succeed to load with sysprep floppy attached (when removing the virtio nic).
Comment 5 Ilanit Stein 2016-02-14 03:41:08 EST
Here a VM was created, and a disk was attached to it, and a nic added. 
Then the VM was sealed, a template created from it. 
Another V< let say VM-1, was created from this template (which has a nic) 
Run once VM-1, with attached floppy [sysprep] 

My expectation was that VM-1 will try to load from network, fail, and then load from disk, with setup run with the sysprep answer file.
 
What happened was that it failed to load from network, and then failed to load from disk: no bootable disk. 

It turned out the attached disk wasn't marked as bootable.
(There is inconsistency here since 1st attached disk is NOT marked as bootable, by default, while it is for add 1st disk)   
Based on that, we can close this bug.

Note You need to log in before you can comment on or make changes to this bug.