This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 130139 - sig 11
sig 11
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-17 10:12 EDT by Wade Mealing
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-09 01:32:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wade Mealing 2004-08-17 10:12:31 EDT
Description of problem:

Kernel panics with "Oops: kernel access of bad area, sig: 11" after
downloading the stage2 image from any of the installation types
nfs/ftp/http/local.

G4 Ibook 1ghz chipset.
1280MB of ram

Version-Release number of selected component (if applicable):


How reproducible:
On this particular Ibook.. every time.. 800mhz version, the installer
works fine.


Steps to Reproduce:
1. Boot from CD/Network image
2. Start install, using any of the methods (http/ftp/nfs/local/cdrom)
3. wait for stage2 to be copied, installer/kernel sig11's.
  
Actual results:

Oops: kernel access of bad area, sig: 11
Oops information below this message talking about cramfs and zlib


Expected results:

Stage 2 file to decompress, install to continue.


Additional info:

Tested additional ram shipped, known good.. tested with 256 onboard..
same problem. System boots gentoo live cd, compiles kernel.. Xfree
without a problem.

Willling to do tests, will do another test, now that partition table
has changed, will report back with results. I am a willing tester !
Comment 1 Colin Charles 2004-08-19 21:19:28 EDT
Additional information about the iBook (from /proc/cpuinfo):
Powerbook6,5
detected as: 287 (iBook G4)
CPU: unknown (80030101)
Motherboard: unknown 287 (Intrepid-based)

This was information from the Gentoo live CD iirc. And the latest
(early-August) commits from benh should make room for the pb6,5's as well
Comment 2 Wade Mealing 2004-08-20 09:15:06 EDT
TASK = EEFF8E6F0[228] 'Loader' Thread: EFADA000 Last Syscall 3
GPR00: FFFC77EF EFADBC20 EFF8E660 F2112420 00000005 FFFFFFFB FFC77F0 00009032
GPR06: F210A408 00000001 F211605C F21423C0 00000000 1012F8FC 0000000 
EF40244C
GPR16: FF211000 FFBC6360 00000000 EFADBF20 EF402400 00000000 0000000 
FFFFFFFB

NIP [C00D7C58] zlib_inflate +0xa81 0x54d
LR: [F2108EC8] cramfs_uncompress_block +0xa81 +0x5d4 [cramfs]

Call trace

[F2108EC8] cramfs_uncompress_block +0x7c / 0xd0 [cramfs]
[F2108D4C] cramfs_readpage +0x190 / 0x286
[C003E26C] read_pages + 0xc0 / 0x120
[C003E630] do_page_each_readahead +0x15c / 0x190
[C003E820] page_cache_readahead +0x1bc / 0x25c
[C0036F2C] do_generic_mapping_read +0x4b / 0x25c
[C0033968] __generic_file_aio_read +0x1cc / 0x1f8
[C0039A74] generic_file_read +0x60 / 0x90
[C0059308] vfs_read + 0x108 / 0x150
[C005959C] sys_read +0x4c / 0x8c
[C0065E00] ret_from_syscall 0x0 0x44

serio: kseriod exiting

I wrote this late at night, so I'm pretty tired when I did it. When I can get a digital cam, i'll 
take another one. No damn serial cable on this ibook.
Comment 3 Colin Charles 2004-08-29 20:26:57 EDT
Just spoke to benh, and he mentioned that the cramfs image you have
could be corrupt, causing zlib to bork. Or it could be corrupt RAM
(maybe its the onboard one?).

Since CPU being unknown, from the Gentoo liveCD shows itself, that's
not entirely a good thing... Linus's BK tree should have more fixes
from benh that should help the 7447 rev1 CPUs (which might very likely
be yours)
Comment 4 Wade Mealing 2004-09-09 01:32:10 EDT
The cramfs image checked out a few times, downloaded many nightly
boot.iso's and stage2.imgs with no luck.

Seemed that the re0903.nightly rawhide fixed the problem.  Extracted
the boot.iso, and completed a http install with no problems.

Installed fine, with no strange errors, no sig11's.. 

Arjan, I know its assigned to you, but I'll change the status to
WORKSFORME, can you try close this ? 

Note You need to log in before you can comment on or make changes to this bug.