Bug 130142 - most icons are missing
most icons are missing
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Depends On:
  Show dependency treegraph
Reported: 2004-08-17 10:20 EDT by Sean Middleditch
Modified: 2013-01-09 22:37 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-02 14:50:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
screenshot showing how many icons are missing (90.51 KB, image/png)
2004-08-17 10:21 EDT, Sean Middleditch
no flags Details
Evo with missing icons (255.10 KB, image/jpeg)
2006-01-14 15:29 EST, Jesse Keating
no flags Details
This problem happens in hicolor-icon-theme-0.9.0 (170.28 KB, image/png)
2006-01-16 21:18 EST, sangu
no flags Details
screenshot from fc5 final when running with KDE (44.84 KB, image/png)
2006-03-21 02:16 EST, Ville Skyttä
no flags Details

  None (edit)
Description Sean Middleditch 2004-08-17 10:20:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803 Epiphany/1.2.7

Description of problem:
The evolution icons seem to be mostly missing.  The "no icon" image
appears in most places in the UI and for the window list icon.  No
other application seems to be exhibiting this behaviour.  This has
persisted for many revision of Evolution.  I have tried completely
uninstalling the evolution packages and reinstalling, and the problem
remained.  I tried changing the GTK theme to both the GNOME default
and Bluecurve (in case it was an issue of the theme missing some stock
icons) and the problem still remained.

Will attach a screenshot.

Also, here is a list of all the png files in Evolution, minus the help
file images.  I would guess there should be more.
elanthis@stargrazer:~$ rpm -ql evolution | grep png | grep -v help

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. start evolution

Additional info:
Comment 1 Sean Middleditch 2004-08-17 10:21:09 EDT
Created attachment 102793 [details]
screenshot showing how many icons are missing
Comment 2 Dave Malcolm 2004-08-17 12:07:10 EDT
What version of the gnome-icon-theme package do you have installed?
Comment 3 Dave Malcolm 2004-08-17 12:12:51 EDT
Works for me with gnome-icon-theme-1.3.6-1; I just checked the list of
icons supplied by gnome-icon-theme-1.2.0-1 (shipped with FC2) and
there are definitely some stock icons that Evo needs that are missing.

Looks like I forgot to update the required version of gnome-icon-theme
when the icons were moved from evolution into the stock package - I'll
bump it to 1.3.6

Does upgrading gnome-icon-theme to 1.3.6 fix it for you?
Comment 4 Sean Middleditch 2004-08-17 12:46:30 EDT
Hmm, looks like the noarch yum bug wasn't making that update for me
like it should have.  Especially odd, since other packages installed
already required gnome-icon-theme >= 1.2 and I only had 1.0.6-1.  Yay

Anyways, I upgraded gnome-icon-theme (rpm -e --nodeps then reinstalled
with yum) and the icons all show up fine now.  Definitely was a
dependency/upgrade issue.  Thank you.
Comment 5 Dave Malcolm 2004-08-17 14:12:48 EDT
Thanks for the info.  OK - I've bumped the required version to 1.3.6
and rebuilt our Evolution packages; this will show up in
evolution-1.5.93-2 which should hit Rawhide tonight.

Resolving as RAWHIDE
Comment 6 Jesse Keating 2006-01-14 15:28:24 EST
Looks like this problem is back.  Screenshot will be attached.

[jkeating@ender ~]$ evolution gnome-icon-theme evolution-data-server redhat-artwork
Comment 7 Jesse Keating 2006-01-14 15:29:38 EST
Created attachment 123205 [details]
Evo with missing icons
Comment 8 sangu 2006-01-16 21:18:10 EST
Created attachment 123283 [details]
This problem happens in hicolor-icon-theme-0.9.0

(In reply to comment #7)
> Created an attachment (id=123205) [edit]
> Evo with missing icons

Downgrading to hicolor-icon-theme-0.8-3.1, this problem doesn't happens.
Comment 9 sangu 2006-01-16 21:22:09 EST
See Also bug 177796
Comment 10 Ville Skyttä 2006-03-21 02:16:42 EST
Created attachment 126375 [details]
screenshot from fc5 final when running with KDE

For me, it's much worse than the other screenshots, see attachment: almost all
icons are broken.

This is a fresh FC5 x86_64 install from scratch, GNOME excluded during
installation and KDE chosen instead.

Comment 11 Ville Skyttä 2006-03-22 15:40:50 EST
The problem is worked around here under KDE like: 
    yum install control-center 
    ln -s /usr/libexec/gnome-settings-daemon ~/.kde/Autostart/ 
Hopefully a better way (something pulling in the required packages and 
automatically starting up the necessary daemons) will appear in the future... 
Comment 12 Juergen Wieczorek 2006-03-26 17:15:16 EST
Precisely the same problem here, when installing FC5 with KDE (less Gnome).
I'll take it as a good chance to get rid of that Ximian crap for good.
Comment 13 Juergen Wieczorek 2006-03-26 17:19:56 EST
(In reply to comment #12)
> Precisely the same problem here, when installing FC5 with KDE (less Gnome).
> I'll take it as a good chance to get rid of that Ximian crap for good.

Still the same with gnome-icon-theme-2.14.2-1.fc5.1
Comment 14 Eduardo N. H. 2006-04-09 23:48:44 EDT
I removed most of gnome from my fc5 installation and the icons broke. After
reinstalling control-center (+dependencries: at-spi and libgail-gnome) using yum
icons kept broken. 
Comment 15 James Athey 2006-04-19 13:43:45 EDT
Try this to get your gtk icons back:

0. If you have gtk-qt-engine installed:
  in KDE's Control Center->Appearance and Themes->GTK styles and fonts, select
"Use another style" and pick Clearlooks.

1. As root, yum install control-center.

2. Run gnome-control-center.

3. Double click the "Theme" control panel.  Just opening this control panel
fixed my icons, but you may have to actually select Clearlooks on your own.
Comment 16 Martin Grotzke 2006-04-20 05:56:33 EDT
Great, installing the control-center and bringing up the Theme control panel
solved the problem for me. Thanx a lot!!
Comment 17 Martin Grotzke 2006-04-21 13:37:28 EDT
Unfortunately, after each restart the icons are missing again, so i have to
restart the procedure.
Comment 18 Ville Skyttä 2006-04-21 16:48:59 EDT
FWIW, and in case you missed it, comment 11 contains a workaround that works for
me across reboot/logout/logins.
Comment 19 Martin Grotzke 2006-04-22 04:11:04 EDT
Thanx for the hint, i really missed that comment.
Comment 21 Matthew Barnes 2006-12-31 17:28:36 EST
It looks like there's a suitable workaround for missing icons in KDE, which is
outside the scope of this bug anyway.

Does anyone using GNOME still see missing Evolution icons in Fedora Core 6?  I'm
guessing this problem, if it still exists, would only manifest after upgrading
from an older Fedora Core release.
Comment 22 Matěj Cepl 2007-08-31 12:14:06 EDT
Could anybody affected by this bug please reply to the previous question? If
there is no reply in one month, this bug will be closed as INSUFFICIENT_DATA.
Thank you.
Comment 23 Matthew Barnes 2007-10-02 14:50:13 EDT

Note You need to log in before you can comment on or make changes to this bug.