Bug 130153 - Error message at adding a new keyboard layout in the menu "prefernces-keyboard"
Error message at adding a new keyboard layout in the menu "prefernces-keyboard"
Status: CLOSED DUPLICATE of bug 125365
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
David Lawrence
:
: 121943 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-17 11:33 EDT by Marton Zsenei
Modified: 2013-04-02 00:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marton Zsenei 2004-08-17 11:33:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
kernel-2.6.5-1.358.i686.rpm

When using the kezboard preferences to add new layouts, the next error
will occur:

Error activating XKB configuration.
Probably internal X server problem.

X server version data:
The X.Org Foundation
60700000


Version-Release number of selected component (if applicable):
system-config-keyboard-1.2.1-2.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1.Add a new kezboard layout by the "prefernces-keyboard" menu.
For example: Hungarian qwerty and there is the error message
2.
3.
    

Actual Results:  ernel-2.6.5-1.358.i686.rpm

When using the kezboard preferences to add new layouts, the next error
will occur:

Error activating XKB configuration.
Probably internal X server problem.

X server version data:
The X.Org Foundation
60700000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2-R /desktop/gnome/peripherals/keyboard/xkb

[root@localhost root]# xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "fr_CH", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "fr_CH", "", ""
[root@localhost root]#


[root@localhost root]# gconftool-2 -R
/desktop/gnome/peripherals/keyboard/xkb
 layouts = [fr_CH,hu    l2_101_qwertz_comma,ru  phonetic]
 model = pc105
 overrideSettings = false
 options = []



Expected Results:  Add to the list a new layout, I suppose.

Additional info:
Comment 1 Paul Nasrat 2004-08-19 03:52:29 EDT
Preferences->keyboard is gnome-keyboard-properties, verified error
occurs - I also get in Xorg.0.log:

(EE) Error loading keymap /usr/X11R6/lib/X11/xkb/compiled/server-0.xkm
(EE) Error loading keymap /usr/X11R6/lib/X11/xkb/compiled/server-0.xkm
Comment 2 sangu 2004-10-30 09:17:01 EDT
Please see : bug 125365, comment 8
Comment 3 Marco Pesenti Gritti 2004-11-04 08:20:25 EST

*** This bug has been marked as a duplicate of 125365 ***
Comment 4 Marco Pesenti Gritti 2004-11-04 08:28:59 EST
*** Bug 121943 has been marked as a duplicate of this bug. ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:05:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.