Bug 1301602 - new disks stay locked
new disks stay locked
Status: CLOSED WORKSFORME
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.5.6.2
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.5
: ---
Assigned To: Daniel Erez
Aharon Canan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-25 08:46 EST by movciari
Modified: 2016-03-21 08:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-03 09:53:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amureini: ovirt‑3.6.z?
ylavi: planning_ack+
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description movciari 2016-01-25 08:46:45 EST
Description of problem:
New disks created when creating new VMs from template or when creating new snapshots stay in status locked.
Some of them already exist for a few days and they're still locked.
There should at lest be some timeout for this, and then it should stop the task and throw an error in webadmin alerts
I don't know how to reproduce this, but it happened old hosted-engine setup with lots of VMs, maybe there will be some clue in logs - I will add links to them in a comment because they're over bugzilla attachment size limit

Version-Release number of selected component (if applicable):
3.5.6.2-0.1.el6ev
Comment 2 Allon Mureinik 2016-01-25 09:01:33 EST
(In reply to movciari from comment #0)
> Version-Release number of selected component (if applicable):
> 3.5.6.2-0.1.el6ev
I'm assuming this is the engine version, right?
Comment 3 Red Hat Bugzilla Rules Engine 2016-01-25 09:01:36 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 4 Allon Mureinik 2016-01-25 09:02:30 EST
Daniel, as QE contact, please take a look?
Comment 5 movciari 2016-01-25 11:18:36 EST
yes, it's engine version
Comment 6 movciari 2016-01-26 08:41:01 EST
For some reason those images are not locked anymore (it took ~5 days)
I didn't do anything special that could affect this, so I don't have any clue why, except some extremely long timeout
Comment 7 Daniel Erez 2016-01-27 00:59:52 EST
Hi Michal,

In order to analyze the issue can you please attach the engine and vdsm logs from the aforementioned ~5 days time period.

Thanks!
Comment 9 Daniel Erez 2016-01-31 08:20:34 EST
Hi Michal,

Is it possible to reproduce the issue and provide 'cleaner' logs. I can't find any 'createVolume' tasks in the given logs that were running for a few days.
Perhaps you remember the specific volume or the time you started the operation? 

Thanks!
Comment 10 Allon Mureinik 2016-03-03 09:53:18 EST
We're unable to reproduce this or gain any insights from the logs, unfortunately.
If you have a reproducer, plesae reopen with the exact steps to rerproduce.
Thanks!
Comment 11 movciari 2016-03-21 08:44:11 EDT
can't reproduce this right now, clearing needinfo

Note You need to log in before you can comment on or make changes to this bug.