Bug 130164 - FC3test1 Disk Druid shows small Free Space between extnd partitions
FC3test1 Disk Druid shows small Free Space between extnd partitions
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-17 12:38 EDT by Bevis King
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-24 04:14:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bevis King 2004-08-17 12:38:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1

Description of problem:
When manually partitioning with Disk Druid, a Free Space entry appears
between each partition in a extended partition; consider this
partition table:

/dev/hda1          /             640MB
/dev/hda2          swap          4096MB
/dev/hda3          /usr          8192MB
/dev/hda4          Extended
   /dev/hda5       /var          512MB
   /dev/hda6       /tmp          4096MB
   /dev/hda7       /opt          Remainder

When entering in Disk Druid, you get:

/dev/hda4          Extended
    Free Space                   < 1 
    /dev/hda5       /var         512MB
    Free Space                   < 1
    /dev/hda6       /tmp         4096MB
    Free Space                   < 1
    /dev/hda7       /opt         20912MB
    Free Space                   < 1


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Partition manually using table above (or similar)
2.
3.
    

Actual Results:  Lots of extraneous small Free Space  < 1MB entries
you have no power to correct.


Expected Results:  If there's no interface to correct it, don't show
sub-cylinder filesystem size errors like these, or modify
implementation to make the partition border to "nearest" complete
cylinder.

Additional info:
Comment 1 Paul Nasrat 2004-08-18 05:05:39 EDT
Hmm this seems to be bug # 119479 again.  It may be my "fix" for
showing small partitions for apple bootstrap only is incorrect.

Investigating
Comment 2 Bevis King 2004-08-18 10:25:27 EDT
I've just tried a different machine, this time an older one with a
20GB disc rather than the brand new one with a 40GB disc; the older
machine didn't show any problems with small blocks of free between
partions.  The issue would appear to only show with certain disc
geometries.  I should be able to get the exact parameters of each disc
if you need them.
Comment 3 Paul Nasrat 2004-08-26 01:58:36 EDT
My logic for Apple_Bootstrap was flawed - which may have caused this.
 I've commited a correct fix to HEAD - could you retest when FC3test2
is released.  

Or I could create an updates.img for you for fc3test1 if you'd prefer.
Comment 4 Bevis King 2004-08-26 06:02:31 EDT
Right now this particular machine is unable to work with FC3test1 as
the standard kernel (as opposed to the boot kernel) does an oops
seconds after booting.  This bug has also been reported.  Once there's
a fixed kernel and the machine might actually work, I'll give it
another try.  At the very least I will be trying FC3test2 on it.

Cheers.

Regards, Bevis.

Note You need to log in before you can comment on or make changes to this bug.