This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1301787 - freeradius-3.0.13 is available
freeradius-3.0.13 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: freeradius (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nikolai Kondrashov
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-25 19:19 EST by Upstream Release Monitoring
Modified: 2017-05-29 12:28 EDT (History)
3 users (show)

See Also:
Fixed In Version: freeradius-3.0.13-2.fc26
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-01 13:07:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[patch] Update to 3.0.11 (#1301787) (1.07 KB, patch)
2016-01-25 19:20 EST, Upstream Release Monitoring
no flags Details | Diff
[patch] Update to 3.0.12 (#1301787) (1.10 KB, patch)
2016-09-29 20:24 EDT, Upstream Release Monitoring
no flags Details | Diff

  None (edit)
Description Upstream Release Monitoring 2016-01-25 19:19:43 EST
Latest upstream release: 3.0.11
Current version/release in rawhide: 3.0.10-1.fc24
URL: http://freeradius.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 1 Upstream Release Monitoring 2016-01-25 19:20:34 EST
Created attachment 1118303 [details]
[patch] Update to 3.0.11 (#1301787)
Comment 2 Upstream Release Monitoring 2016-05-16 22:17:08 EDT
jplesnik's freeradius-3.0.11-2.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=765872
Comment 3 Upstream Release Monitoring 2016-09-27 06:15:45 EDT
nkondras's freeradius-3.0.11-3.fc26 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=804764
Comment 4 Upstream Release Monitoring 2016-09-29 20:21:17 EDT
Latest upstream release: 3.0.12
Current version/release in rawhide: 3.0.11-3.fc26
URL: http://freeradius.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/853/
Comment 5 Upstream Release Monitoring 2016-09-29 20:22:37 EDT
Rebase helper failed.
See logs and attachments in this bugzilla 'NoneType' object has no attribute 'get_rebasehelper_data'
Comment 6 Upstream Release Monitoring 2016-09-29 20:24:02 EDT
Created attachment 1206086 [details]
[patch] Update to 3.0.12 (#1301787)
Comment 7 Upstream Release Monitoring 2017-02-20 13:17:25 EST
nkondras's freeradius-3.0.12-2.fc26 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=860490
Comment 8 Upstream Release Monitoring 2017-03-07 19:12:44 EST
Latest upstream release: 3.0.13
Current version/release in rawhide: 3.0.12-2.fc26
URL: http://freeradius.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/853/
Comment 9 Upstream Release Monitoring 2017-03-07 19:12:51 EST
An unexpected error occured creating the scratch build: please report this issue to the-new-hotness issue tracker at https://github.com/fedora-infra/the-new-hotness/issues
Comment 10 Fedora Update System 2017-03-08 02:06:37 EST
freeradius-3.0.13-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-ef26f4f1d5
Comment 11 Arnab Roy 2017-03-10 06:57:01 EST
Upgrade to 3.0.12 results the following error 

SOFT ASSERT FAILED src/modules/rlm_perl/rlm_perl.c[703]: *vps

when rlm_perl . This has been patched on 3.0.13..do you have an idea when it might be released.
Comment 12 Nikolai Kondrashov 2017-03-10 07:06:03 EST
3.0.13 was released by upstream. We have it in testing for Fedora 26 currently: https://bodhi.fedoraproject.org/updates/FEDORA-2017-ef26f4f1d5
Comment 13 Fedora Update System 2017-03-10 18:21:36 EST
freeradius-3.0.13-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-ef26f4f1d5
Comment 14 Arnab Roy 2017-03-11 05:22:57 EST
Following installation Freeradius Fails to start with libssl version mismatch.  built: 1010005f linked: 1010004f

The installed Openssl version is openssl-1.1.0d-3.fc26.x86_64
Comment 15 Nikolai Kondrashov 2017-03-13 03:07:38 EDT
Thank you for the report. I reopened Bug 1299388 which discussed this at length and needs to be resolved.
Comment 16 Fedora Update System 2017-03-15 11:21:13 EDT
freeradius-3.0.13-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-97cc5cb6d6
Comment 17 Fedora Update System 2017-03-15 20:50:54 EDT
freeradius-3.0.13-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-97cc5cb6d6
Comment 18 Fedora Update System 2017-04-01 13:07:50 EDT
freeradius-3.0.13-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 19 Arnab Roy 2017-05-29 12:28:29 EDT
I am experiencing a crash on 3.0.13.2-fc26 caused by tls session caching when the eap session is not previously closed out properly.

Looks like 3.0.14 has a fix ?? Any ETA's?

The internal OpenSSL session cache has been disabled. Please see mods-available/eap

Note You need to log in before you can comment on or make changes to this bug.